aspose file tools*
The moose likes Mac OS and the fly likes JDK 1.4 Updates broke something on OS X Tiger Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Engineering » Mac OS
Bookmark "JDK 1.4 Updates broke something on OS X Tiger" Watch "JDK 1.4 Updates broke something on OS X Tiger" New topic
Author

JDK 1.4 Updates broke something on OS X Tiger

Unnsse Khan
Ranch Hand

Joined: Nov 12, 2001
Posts: 511
Hello again,

I am using a G4 PowerBook running OS X Tiger... Ran the software update, last night, and discovered that Apple had updates for the JDK 1.3 & 1.4.2.

Figuring that I might be in project which requires these versions, I chose to allow the software update application to download and install these respective patches.

Well, earlier today, I was trying to invoke a simple Ant build script and received the following error:



As one can, see my Ant process became paused...

Since, I had installed these updates, last night, and had written an Ant build script (which worked), yesterday, I assumed / guessed that it was the updates that caused this problem.

Therefore, I checked my JAVA_HOME and .bash_profile:



When I did a simple check of "java -version", this is what I got:



My questions:

1. Which version am I using?

2. Why is Ant's functionality broken?

3. Has anyone experienced the same problem after downloading & installing these updates?

4. How do I switch my "java -version" to point to JDK 1.5 ($JAVA_HOME)?

Any tips and suggestions will be greatly appreciated...

Many, many thanks!
Unnsse Khan
Ranch Hand

Joined: Nov 12, 2001
Posts: 511
Ok...

I switched the CurrentJDK to 1.5.0 by doing this:

1. sudo su root
2. cd /System/Library/Frameworks/JavaVM.framework/Versions
3. rm CurrentJDK
4. ln �s 1.5.0 CurrentJDK
5. exit

Ok, now when I re-ran Terminal and typed java -version, I still had the same error!



Why is it stating: "HotSpot not at correct virtual address. Sharing disabled."? Has anyone experienced this? Everything was working two days, ago. This all happened after I downloaded & installed the JDK 1.3 & 1.4.2 patches offered via the Software Update utility from Apple.

I am unable to even use Ant, now, because of this...

Hopefully, someone could suggest something?

Kindest regards,
marc weber
Sheriff

Joined: Aug 31, 2004
Posts: 11343

Some users on the Apple boards have reported that using Pacifist with the latest Java 5.0 update resolves the issue.
[ September 21, 2005: Message edited by: marc weber ]

"We're kind of on the level of crossword puzzle writers... And no one ever goes to them and gives them an award." ~Joe Strummer
sscce.org
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JDK 1.4 Updates broke something on OS X Tiger
 
Similar Threads
Problem running code with JDK 1.5
Help installing JWSDP 1.6 on OS X Tiger
J2ME for OS X?
Problem running Tomcat 5.5.9 on OS X Tiger
Problem running Tomcat 5.5.9 on OS X Tiger