File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Mac OS and the fly likes Java Plugin instability Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Mac OS
Bookmark "Java Plugin instability" Watch "Java Plugin instability" New topic

Java Plugin instability

Ulf Dittmer

Joined: Mar 22, 2005
Posts: 42965
The Java support both on Safari and FireFox has become really unstable on my machine (i.e., many applets which -even those that used to work- now crash either browser). I wonder it I still have the correct plugin files, or if some of those are obsolete by now. In /Library/Internet Plugins I have:

MRJPlugin.plugin (MRJ Plugin version 1.0-JEP-0.9.4)
Java Applet.plugin (10.0.2 for Java 1.3.1)
JavaPluginCocoa.bundle (10.0.2 for Java 1.4.2)
Java Applet Plugin Enabler (no version)
JavaEmbeddingPlugin.bundle (0.9.4)

Are some of these obsolete and can be removed? I also thought that JEP was now part of FireFox; is it still a Plugin, so that I could remove the the respective files from the plugins folder?

I'm using Java 1.4.2 on OS X 10.4.7
I agree. Here's the link:
subject: Java Plugin instability
jQuery in Action, 3rd edition