aspose file tools*
The moose likes XML and Related Technologies and the fly likes Xerces 1.4.4 with JDK 1.3.1_01 schema validation problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » XML and Related Technologies
Bookmark "Xerces 1.4.4 with JDK 1.3.1_01 schema validation problem" Watch "Xerces 1.4.4 with JDK 1.3.1_01 schema validation problem" New topic
Author

Xerces 1.4.4 with JDK 1.3.1_01 schema validation problem

Anonymous
Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
I am attempting to run the DOMCount example that comes with Xerces 1.4.4. When I turn the "-v" switch on for validation against a schema I receive the following error when using Sun's JDK 1.3.1_01:

I am stumped because the example runs fine when I run it under Sun's JDK 1.4.
I am guessing that there must be an old version of some XML class in the 1.3.1_01 JDK. Any suggestions on which class this might be or if there is an API that I need if I want to stick with JDK 1.3.1_01.
Any help is appreciated.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Xerces 1.4.4 with JDK 1.3.1_01 schema validation problem