• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

How to solve j2sdk1.4.1_01 xml library conflict problem?

 
Roseanne Zhang
Ranch Hand
Posts: 1953
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
j2sdk1.4.1_01 rt.jar included some xerces/xalan parser to use. However, if I want to use the latest version of xalan, and put it in classpath, then I got a LoaderError:
"XSLT Error (java.lang.LinkageError): loader constraints violated when linking org/xml/sax/InputSource class"
Does anyone know how to solve the problem? Obviously, we cannot get rid of rt.jar. It seems pretty stupid to bundle them together to me.
Any help will be appreciated very much.
 
Dave Morris
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
may be a stupid question from me, why u want to use jdk1.4.1_01 instead of jdk1.3.1 or jdk1.4.0 ?
with jdk1.4.0 i can able to use latest version of xalan.jar
rgds
balaji
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic