This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Internet Explorer is unable to open Office documents from an SSL Web site

 
pk chaurasia
Greenhorn
Posts: 5
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi

my problem is-
"Internet Explorer is unable to open Office documents from an SSL Web site"

in my application.

The error is-

"The page cannot be displayed.
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.
Cannot find server or DNS Error"

after removing responce.setHeaders(catch-control, no-chache), I also fase the same problem.

Thanks.
Pramod
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You have not provided enough information for us to help you. I have read the post twice and I'm not even sure if we're talking about a Java application, let alone which forum this should be discussed in.
 
Ernest Friedman-Hill
author and iconoclast
Marshal
Pie
Posts: 24204
34
Chrome Eclipse IDE Mac OS X
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This isn't a Java question in any way, shape or form, let along an advanced one. Moving to "General Computing".
 
Paul Clapham
Sheriff
Pie
Posts: 20196
26
MySQL Database
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Although
responce.setHeaders(catch-control, no-chache)
suggests that the question might possibly be about a servlet running on the server in question...
 
Katrina Owen
Sheriff
Pie
Posts: 1367
18
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"pk chaurasia",

Please check your private messages for an important message from me.

Kind regards,
Katrina Owen
JavaRanch Saloon Bartender
 
Rahul Bhattacharjee
Ranch Hand
Posts: 2308
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by pk chaurasia:

"The page cannot be displayed.
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

Just interpreting the response message.

Doesn't look like a standard MSIE message.

Seems like this is one of the standard IIS error message.

Might be its a issue with server .The requested file might not be available.
Does the application under consideration allows to view the same file without SSL ? If Yes , try to see if you get the same error without SSL.
 
Tim McGuire
Ranch Hand
Posts: 820
IntelliJ IDE Tomcat Server VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi. I just dealt with this same problem
https download of generated Excel file works fine in Firefox, but IE refuses to download it.

http works fine in both browsers.

The issue is that you need to set some headers for IE
The following worked for me:


references:
http://support.microsoft.com/kb/812935
http://joseph.randomnetworks.com/archives/2004/10/01/making-ie-accept-file-downloads
http://forum.java.sun.com/thread.jspa?threadID=586671
 
Amy Saari
Ranch Hand
Posts: 30
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You will see this problem using SSL and IE while trying to download files. It's an IE bug (surprise) - read about it here:

http://support.microsoft.com/kb/316431
 
david lightman
Ranch Hand
Posts: 82
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
seeing the exact same issue. IE is connecting to IBM http server (apache) and will not open the excel doc. However firefox works fine.

we do not want to change the registry for each client and would rather make the change on the IHS. It appears we need to make this change in httpd.conf? something called mod_headers??

any help is appreciated. thanks
 
Raj Purohit
Greenhorn
Posts: 10
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Tim McGuire,

Thanks for the solution. It is working fine in my app.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic