aspose file tools*
The moose likes Security and the fly likes IPSCA error with jdk1.3.1_04 and below jdk1.4 ver Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » Security
Bookmark "IPSCA error with jdk1.3.1_04 and below jdk1.4 ver" Watch "IPSCA error with jdk1.3.1_04 and below jdk1.4 ver" New topic
Author

IPSCA error with jdk1.3.1_04 and below jdk1.4 ver

senthil sen
Ranch Hand

Joined: Oct 10, 2002
Posts: 184
I have sslclass that implements an interactive Trust Manager and prompts the user if a server certificate is not trusted,and adds them to the truststore if chosen by the user.Unfortunately, it gives us a java nullPointerException
The Certificate is issued by IPSCA and jdk version is 1.3.1_04, only this certificate from IPSCA with jdk1.3.1_04 or below jdk1.4 ver is giving this problem , other certificates with 1.3.1_04 is OK.
I am unable to upgrade to 1.4 or higher since is not feasible, due to incompatibilities.
The following is the error Iam getting :

bash-2.03$ Classssl hdy.mjuer.com 987
Trying SSL connection with nmjdj.mfju.com:987
ERROR:Error initializing KeyStore! java.io.IOException:
java.lang.NullPointerException

Any ideas or any suggestions..........
Thanks in advance....
senthil sen
Ranch Hand

Joined: Oct 10, 2002
Posts: 184
I found out that my server certificate has signature algorithm as "md5RSA"
My client certificate has signature algorithm as "SHA1"
Both are from same CA.
Could this be the problem???
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: IPSCA error with jdk1.3.1_04 and below jdk1.4 ver