This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Security and the fly likes Page don't work with SSL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » Security
Bookmark "Page don Watch "Page don New topic
Author

Page don't work with SSL

Lu�s Matos
Greenhorn

Joined: Nov 09, 2005
Posts: 12
Hi

For a long time that I'm trying to configure tomcat to work with SSL.

My last try is on Windows 2003 Standard with JRE 1.5.0_08 and Tomcat 5.5.17.

I try this example: http://tomcat.apache.org/tomcat-5.5-doc/ssl-howto.html
I create the .keystore in C:\Documents and Settings\Administrator\ and use the password by default (changeit).
I uncomment the SSL connector and leave by default (I try others configurations).
I give the same passaword (changeit) to the tomcat administration.

My prblem is: Every time that I open https://localhost:8443 the page try to open for a long time (~1 minute) and finally give me the erro: Cannot find server.

Anyone can help me? I don't know more what to do.

Thanks a lot for the help.
Lu�s Matos
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41089
    
  44
Have you tried https://127.0.0.1:8443/? Does http://localhost:8080/ work?


Ping & DNS - my free Android networking tools app
Lu�s Matos
Greenhorn

Joined: Nov 09, 2005
Posts: 12
Hi Ulf Dittmer

Thanks for your reply.

http://localhost:80 and http://127.0.0.1:80 - Work (I have installed in port 80).
https://127.0.0.1:8443 - have the same problem (try to open then I got the error).

This is my server.xml file:

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Page don't work with SSL
 
Similar Threads
ssl with Tomcat
Can't display web app security
Redirecting to HTTPS
configuring https with tomcat - issue
Unable to get authentication and authorization working.