Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

~LoginException: No LoginModules configured

 
Andrea Modica
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I receive this error
javax.security.auth.login.LoginException: No LoginModules configured

when I call LogincContext class from a JSP even if I put the following line in my java.security file

login.config.url.1=file:${java.home}/lib/security/config.pd

here the content of config.pd file

pd-debug {
com.tivoli.pd.jazn.PDLoginModule required debug=true;
};
pd {
com.tivoli.pd.jazn.PDLoginModule required;
};
pd-nopass {
com.tivoli.pd.jazn.PDLoginModule required nameOnly=false;
};

Any idea?
 
Rahul Bhattacharjee
Ranch Hand
Posts: 2308
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Andrea Modica:
Hi
I receive this error
javax.security.auth.login.LoginException: No LoginModules configured

when I call LogincContext class from a JSP even if I put the following line in my java.security file

login.config.url.1=file:${java.home}/lib/security/config.pd

here the content of config.pd file

pd-debug {
com.tivoli.pd.jazn.PDLoginModule required debug=true;
};
pd {
com.tivoli.pd.jazn.PDLoginModule required;
};
pd-nopass {
com.tivoli.pd.jazn.PDLoginModule required nameOnly=false;
};

Any idea?


Your config.pd seems to be ok.
Can you post the java code.
It should be something like below

LoginContext lc = new LoginContext("pd"); // or pd might be something else from the configuration
lc.login(..);
 
Andrea Modica
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks
but I solved the problem configuring the stanza PD login directly on WebSphere admin console.
 
Behzad Salami
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, could you please tell us how you configured the PD Stanza ? I'm having the same issue and my config.pd looks identical.
Also I have created the jaas.policy, modified java.policy and java.security and nothing seems to be working.

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic