Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
The moose likes Web Services Certification (SCDJWS/OCEJWSD) and the fly likes problem with wsdl2java in Axis Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Web Services Certification (SCDJWS/OCEJWSD)
Bookmark "problem with wsdl2java in Axis" Watch "problem with wsdl2java in Axis" New topic

problem with wsdl2java in Axis

thakur thakur

Joined: Dec 06, 2002
Posts: 9
I tired to get some answers from Axis/SOAP mailing list on this but couldn't-

I am using Axis-1_1 and using the standard packages that come with Axis.
I am using WSDL2Java to gernerate the stubs doing the standard way-

org.apache.axis.wsdl.WSDL2Java <>

I get the following error 'invalid endpoint address' for any wsdl that come with the samples. I did some search on the web and I learned that I should be using ssl package (jsse.jar) and use the following command-

Java -
org.apache.axis.wsdl.WSDL2Java -o \src -p samples.stock GetQuote.wsdl

I still get the same error??

I welcome any suggestions from the followers of Axis or Authors of WebServices-

James Wang
Ranch Hand

Joined: Sep 04, 2003
Posts: 102
I think that it is not part of this exam objects

YH Lai

Joined: Apr 15, 2004
Posts: 16

Java org.apache.axis.wsdl.WSDL2Java -p samples.stock http://<yourservername>/<webapp>/<yourwebservice>?GetQuote.wsdl


Java org.apache.axis.wsdl.WSDL2Java -p samples.stock http://localhost/BasicWS/Basic.jws?GetQuote.wsdl
I agree. Here's the link:
subject: problem with wsdl2java in Axis
It's not a secret anymore!