wood burning stoves 2.0*
The moose likes Architect Certification (SCEA/OCMJEA) and the fly likes Problem running petstore demo Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Certification » Architect Certification (SCEA/OCMJEA)
Bookmark "Problem running petstore demo" Watch "Problem running petstore demo" New topic
Author

Problem running petstore demo

Jeff Wachhorst
Ranch Hand

Joined: Mar 09, 2004
Posts: 41
I'm trying to run the petstore demo. I've downloaded the demo, I'm following the directions on \petstore1.3.2\docs\installing.html, everything goes great till I get to the bottom of installing.html where it says this:

Run the setup script to deploy the applications.

If you are using Unix, open a shell prompt and enter these commands:

cd <petstore.home>
sh setup.sh deploy

If you are using Windows, open a command prompt and enter these commands:

cd <petstore.home>
setup.bat deploy


My machine is running Windows 2000. Here's what happens when I enter the command setup.bat deploy at my command prompt:

C:\petstore\petstore1.3.2>setup.bat deploy
Buildfile: setup.xml

init:

deploy:
[echo] Deploying ears ....

BUILD FAILED

C:\petstore\petstore1.3.2\setup.xml:231: Execute failed: java.io.IOException: CreateProcess: \bin\deploytool.bat -generateSQL

petstore.ear localhost error=3
--- Nested Exception ---
java.io.IOException: CreateProcess: \bin\deploytool.bat -generateSQL petstore.ear localhost error=3
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
at java.lang.ProcessImpl.start(ProcessImpl.java:30)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
at java.lang.Runtime.exec(Runtime.java:591)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:509)
at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:329)
at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:228)
at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:162)
at org.apache.tools.ant.Target.execute(Target.java:153)
at org.apache.tools.ant.Project.runTarget(Project.java:898)
at org.apache.tools.ant.Project.executeTarget(Project.java:536)
at org.apache.tools.ant.Project.executeTargets(Project.java:510)
at org.apache.tools.ant.Main.runBuild(Main.java:421)
at org.apache.tools.ant.Main.main(Main.java:149)

Total time: 3 seconds

C:\petstore\petstore1.3.2>

The last line on installing.html is: After installing the demo, you can start using it .
I click on 'using it' which takes me to /petstore1.3.2/docs/using.html#ataglance. There, under 'Using the Storefront', I click on the link http://localhost:8000/petstore. I get the HTTP status 404 screen - The requested resource (/petstore/) is not available.

Can anyone help me?

THANK YOU in advance-
Jeff Wachhorst
Ranch Hand

Joined: Mar 09, 2004
Posts: 41
I found my error. If you don't change your environment variables at MyComputer>Properties>Advanced>Environment Variables and instead set them with a script (as I did), that script has to be run (and those environment variables set) once in every command prompt window you open. I'm thinking that if they had computers in the classroom when I was in elementary and high school, I might know this kind of thing..
Anyway, I've successfully completed Installing and Building the demo and I find the API for the PetStore, containing the javadocs for everything in the PetStore demo but I still can't find an HTML index for the source code which you get when you click on 'Browseable source code' at http://java.sun.com/blueprints/code/jps132/docs/index.html
Have I missed something?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem running petstore demo