Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

deploytool fails on startup (mac os x)

 
Vera Pawlowski
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I installed the J2EE SDK 1.3 linux version on my mac. J2EE application server starts up fine, but the deploytool keeps failing on startup. I am getting the following error:
> deploytool -ui
/Users/vera/Applications/j2sdkee1.3.1/bin/deploytool: line 19: 466
Segmentation fault $JAVACMD -classpath "$CPATH_CH"
$SYSTEM_PROPERTIES com.sun.enterprise.tools.deployment.main.Main "$@"
Any ideas why that is happening? Does anyone run this successfully on Mac Os X? Help is highly appreciated!
 
Cleland Early
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The default installation of Mac OS X doesn't include the J2EE classes. However, you can download XCode 1.1 tools from the Apple developer site which includes a tweaked version of JBoss that runs out of the box on Mac OS X (use the custom install option when you run the installers). JBoss features hot deployment, so all you have to do is drag your ejb jar to the deployment directory, making the deployment tool superfluous. If you run JBoss in a terminal window, you can watch the debugging information as JBoss attempts to deploy your application.
[ March 09, 2004: Message edited by: Cleland Early ]
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic