my dog learned polymorphism*
The moose likes EJB Certification (SCBCD/OCPJBCD) and the fly likes Help - J2EE RI Server not running Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Certification » EJB Certification (SCBCD/OCPJBCD)
Bookmark "Help - J2EE RI Server not running" Watch "Help - J2EE RI Server not running" New topic
Author

Help - J2EE RI Server not running

Rajesh Srivastava
Greenhorn

Joined: May 14, 2004
Posts: 25
Hi,
I am new to J2EE. While trying to start J2EE 1.3 RI Server I recieved
following error message. I used a Win 2000 server operating system
with following settings.

JAVA_HOME : C:\jdk1.3.0_01
J2EE_HOME : C:\j2sdkee1.3.1
path : .;\C:\j2sdkee1.3.1\bin;C:\jdk1.3.0_01\bin;
CLASSPATH : .;C:\j2sdkee1.3.1\lib;C:\j2sdkee1.3.1\lib\j2ee.jar;
C:\jdk1.3.0_01\jre\lib;C:\jdk1.3.0_01\jre\lib\rt.jar;

Shall be glad if someone helps me out.

C:\>j2ee -verbose
J2EE server listen port: 1050
Naming service started:1050
Exception in thread "main" java.lang.NoSuchMethodError
at com.sun.corba.ee.internal.corba.AnyImpl.createTypeCodeForClass(AnyImpl.java:1256)
at com.sun.corba.ee.internal.iiop.ShutdownUtilDelegate.createTypeCode(ShutdownUtilDelegate.java:223)
at com.sun.corba.ee.internal.iiop.ShutdownUtilDelegate.writeAny(ShutdownUtilDelegate.java:178)
at javax.rmi.CORBA.Util.writeAny(Util.java:80)
at org.omg.stub.com.sun.enterprise.naming._SerialContextProvider_Stub.rebind(Unknown Source)
at com.sun.enterprise.naming.SerialContext.rebind(SerialContext.java:188)
at com.sun.enterprise.naming.SerialContext.rebind(SerialContext.java:202)
at javax.naming.InitialContext.rebind(InitialContext.java:370)
at com.sun.enterprise.naming.NamingManagerImpl.publishObject(NamingManagerImpl.java:192)
at com.sun.enterprise.naming.NamingManagerImpl.publishObject(NamingManagerImpl.java:149)
at com.sun.enterprise.server.J2EEServer.bindObject(J2EEServer.java:718)
at com.sun.enterprise.server.J2EEServer.createServerObject(J2EEServer.java:473)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:244)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:972)
Joyce Lee
Ranch Hand

Joined: Jul 11, 2003
Posts: 1392
Rajesh, I didn't have this problem with win2000.

Here are my settings:
PATH=c:\j2sdk1.4.1_03\bin;c:\j2sdkee1.3.1\bin
CLASSPATH=.;c:\j2sdkee1.3.1\lib\j2ee.jar
J2EE_HOME=c:\j2sdkee1.3.1
JAVA_HOME=c:\j2sdk1.4.1_03

Joyce
Rajesh Srivastava
Greenhorn

Joined: May 14, 2004
Posts: 25
Thanx Joyce,
It worked well and finally I could run the J2EE RI server and successfully deployed an EJB.
I think it is the change of JSDK version from 1.3 to 1.4 that worked.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Help - J2EE RI Server not running