aspose file tools*
The moose likes EJB Certification (SCBCD/OCPJBCD) and the fly likes Advisor error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Certification » EJB Certification (SCBCD/OCPJBCD)
Bookmark "Advisor error" Watch "Advisor error" New topic
Author

Advisor error

Chetan Sahasrabudhe
Ranch Hand

Joined: Aug 09, 2004
Posts: 75
Hello,

As part of headfirst ejb reading, I am creating all the projects explained in the book.

I am using RI for deployment purpose.

I am able to deploy the Advice Bean and compile my client file with the stub generated by RI.

When I try to run the client it throws following error.
I am trying to figureout what is wrong, but cant makeout where the problem is. (the verifier worked find and returned no errors).
Here is the dump........
E:\Chetan\Work\SCBCD\projects\advice>java -cp %classpath%;AdviceAppClient.jar AdviceClient
Gettign context
lookup found
Got home object
created success
java.rmi.RemoteException: CORBA BAD_OPERATION 0 No; nested exception is:
org.omg.CORBA.BAD_OPERATION: vmcid: 0x0 minor code: 0 completed: No
at com.sun.corba.ee.internal.iiop.ShutdownUtilDelegate.mapSystemException(ShutdownUtilDelegat
.java:137)
at javax.rmi.CORBA.Util.mapSystemException(Unknown Source)
at headfirst._Advice_Stub.getAdvice(Unknown Source)
at AdviceClient.go(AdviceClient.java:27)
at AdviceClient.main(AdviceClient.java:10)
Caused by: org.omg.CORBA.BAD_OPERATION: vmcid: 0x0 minor code: 0 completed: No
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at com.sun.corba.ee.internal.iiop.messages.ReplyMessage_1_2.getSystemException(ReplyMessage_1
2.java:93)
at com.sun.corba.ee.internal.iiop.ClientResponseImpl.getSystemException(ClientResponseImpl.ja
a:108)
at com.sun.corba.ee.internal.POA.GenericPOAClientSC.invoke(GenericPOAClientSC.java:132)
at org.omg.CORBA.portable.ObjectImpl._invoke(Unknown Source)
at headfirst._Advice_Stub.getAdvice(Unknown Source)
... 2 more


Thanks & Regards<br />Chetan
rishi rishi
Greenhorn

Joined: Sep 13, 2004
Posts: 1
U may have to cheking the EJB-RDB mapping for the cmp fields.
Susanta Chatterjee
Ranch Hand

Joined: Aug 12, 2002
Posts: 102
This is an error in Sun J2EE RI. Click here for workaround.
Chetan Sahasrabudhe
Ranch Hand

Joined: Aug 09, 2004
Posts: 75
Hello,

Greaaaaaaaaaaaat it worked, yep the RI has the bug that does not allow interface name with get<<interface name>>.

Thanks for the help.
Regards
Chetan
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Advisor error