jQuery in Action, 2nd edition*
The moose likes EJB Certification (SCBCD/OCPJBCD) and the fly likes Problem Running the AdviceClient Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Certification » EJB Certification (SCBCD/OCPJBCD)
Bookmark "Problem Running the AdviceClient" Watch "Problem Running the AdviceClient" New topic
Author

Problem Running the AdviceClient

Nitin Dindorkar
Greenhorn

Joined: Nov 14, 2003
Posts: 6
Hi I have confirmed few times that the environment setting are correct. Client complies fine.
Run fine until the program call getMessage();
Error Message is as below:

=============================================
java.rmi.AccessException: CORBA NO_PERMISSION 0 No; nested exception is:
org.omg.CORBA.NO_PERMISSION: vmcid: 0x0 minor code: 0 completed: No
at com.sun.corba.ee.internal.iiop.ShutdownUtilDelegate.mapSystemExceptio
n(ShutdownUtilDelegate.java:87)
at javax.rmi.CORBA.Util.mapSystemException(Util.java:65)
at headfirst._AdviceHome_Stub.getHomeHandle(Unknown Source)
at AdviceClient.main(AdviceClient.java:18)
Caused by: org.omg.CORBA.NO_PERMISSION: vmcid: 0x0 minor code: 0 completed:
No
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstruct
orAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingC
onstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
at java.lang.Class.newInstance0(Class.java:306)
at java.lang.Class.newInstance(Class.java:259)
at com.sun.corba.ee.internal.iiop.messages.ReplyMessage_1_2.getSystemExc
eption(ReplyMessage_1_2.java:93)
at com.sun.corba.ee.internal.iiop.ClientResponseImpl.getSystemException(
ClientResponseImpl.java:108)
at com.sun.corba.ee.internal.POA.GenericPOAClientSC.invoke(GenericPOACli
entSC.java:136)
at org.omg.CORBA.portable.ObjectImpl._invoke(ObjectImpl.java:457)
... 2 more
=================================================================

If some one can help please.Also I am using J2ee 1.4 if that is the problem.

Thank you.
Nitin
Chengwei Lee
Ranch Hand

Joined: Apr 02, 2004
Posts: 884
Hi there,

You're question had been posted & answered before in this forum. All you had to do was to do a search for it.

Anyway, there is a bug with the Reference Implementation that you're using. You can't have a method name that has the same characters as the interface name. A bug with the RI, not the EJB Specs. So the workabout is to rename the method.

You could also find this piece of information in the official errata.

Cheers.


SCJP 1.4 * SCWCD 1.4 * SCBCD 1.3 * SCJA 1.0 * TOGAF 8
Nitin Dindorkar
Greenhorn

Joined: Nov 14, 2003
Posts: 6
Thank you, I am already using a different method name then the interface name, I read about that on Kathy's wickedlysmart web site. My method name is "getMessage()"
Serkan Yazici
Ranch Hand

Joined: Apr 24, 2004
Posts: 33
Hi Nitin,

I had the same problem (not the CORBA BAD_OPERATION but NO_PERMISSION exception). I did a search here and found the following suggestion:

Originally posted by Dan Young:
Just a small addendum:

Tried all KS's suggested remedy steps. Got the following:

java.rmi.AccessException: CORBA NO_PERMISSION

Poked around on Google and found this:

With 1.3.1 final release, the J2EE SDK became strict about checking adherence to the security policies of J2EE components.

Fix:

Under the Security screen of the EJB wizard or the Security tab of the EJB inspector in deploytool, click "Deployment Settings..". Under the box "Client Authentication", make sure "Support Client Choice" is checked instead of "Certificate" or "Password".

2. Using Deploytool click "Update & Redeploytool"

3. Run you standalone client again

Cheers,
DY


I'm using J2EE 1.3.1 and it solved my problem. Hope it helps.


-- SCJP 1.4 (98%), SCJD (98%), SCWCD (96%), OCA Dev (97% avg.), SCBCD (97%), SCJP 1.5 BETA (90%)<br />-- OCP Dev (maybe), MCDBA (probably) SCEA (eventually)<br />-- Haven't tried Firefox yet? Free, open, secure, fast, tabified, and slick!<br />-- <a href="http://www.mozilla.org/products/firefox/" target="_blank" rel="nofollow">http://www.mozilla.org/products/firefox/</a>
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem Running the AdviceClient
 
Similar Threads
how to connect EJB without using runclient
java.rmi.AccessException
getting java.rmi.AccessException: CORBA NO_PERMISSION
java.rmi.accessexception
CORBA.NO_PERMISSION Exception