aspose file tools*
The moose likes EJB Certification (SCBCD/OCPJBCD) and the fly likes Does j2ee 1.3 with j2se 1.4 work OK? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » EJB Certification (SCBCD/OCPJBCD)
Bookmark "Does j2ee 1.3 with j2se 1.4 work OK?" Watch "Does j2ee 1.3 with j2se 1.4 work OK?" New topic
Author

Does j2ee 1.3 with j2se 1.4 work OK?

Mike Gershman
Ranch Hand

Joined: Mar 13, 2004
Posts: 1272
I notice that I am advised to use j2ee 1.3 with hfejb. How does this work with j2se 1.4? with j2se 1.5?

What problems would result from using hfejb with j2ee?

I want to study hfejb and hfs in parallel and am afraid of having too many software versions on my PC. If they interfere with each other, I currently lack the expertise to tell whether an error is me or the software and what to do about it.


Mike Gershman
SCJP 1.4, SCWCD in process
Valentin Crettaz
Gold Digger
Sheriff

Joined: Aug 26, 2001
Posts: 7610
The fact is that this exam is based on the J2EE 1.3 specification and that the latter requires that (J2EE.2.3.1) J2SE 1.3 be used. If you use J2SE 1.4 instead you might run into problems due to the backward incompatibilities or similar issues. This page lists all novelties introduced in J2SE 1.4. As you can see, there are many things that could go wrong


SCJP 5, SCJD, SCBCD, SCWCD, SCDJWS, IBM XML
[Blog] [Blogroll] [My Reviews] My Linked In
Karl Brodowsky
Greenhorn

Joined: Feb 28, 2005
Posts: 1
I do not see any problems running J2EE 1.3 with J2SE 1.4.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Does j2ee 1.3 with j2se 1.4 work OK?