aspose file tools*
The moose likes EJB Certification (SCBCD/OCPJBCD) and the fly likes Not Able To Run The Advice App Client given in Head First EJB Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Certification » EJB Certification (SCBCD/OCPJBCD)
Bookmark "Not Able To Run The Advice App Client given in Head First EJB" Watch "Not Able To Run The Advice App Client given in Head First EJB" New topic
Author

Not Able To Run The Advice App Client given in Head First EJB

Sandeep Prabhakar
Ranch Hand

Joined: Dec 22, 2005
Posts: 59
Hey Ranchers,
I am not able to run the Advice App example given in Head First EJB book.
I went through this "http://www.coderanch.com/t/161481/java-EJB-SCBCD/certification/AdviceClient-Solution" but was not able to run.
Here are the settings of my environment variables (I am using a WINDOWS machine).
CLASSPATH = C:\j2sdkee1.3.1\lib\j2ee.jar;C:\projects\advice
J2EE_HOME = C:\j2sdkee1.3.1
JAVA_HOME = C:\jdk1.4.1
PATH = C:\j2sdkee1.3.1\bin;C:\jdk1.4.1\bin;C:\j2sdkee1.3.1\bin\j2ee.jar;


I am able to compile the client program.
However when I try to run it, the get the following errors
Can any one please let me know what is wrong???

For compiling, I used the following command
"javac -classpath .\classes;C:\j2sdkee1.3.1\lib\j2ee.jar Advic
eClient.java"

For Running, I used the following command
"java -classpath .\classes;AdviceAppClient.jar;C:\j2sdkee1.3.1
\lib\j2ee.jar; AdviceClient"

Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/corba/se/internal/util/JDKBridge
at com.sun.corba.ee.internal.core.IOR$LocalCodeBaseSingletonHolder.<clin
it>(IOR.java:90)
at com.sun.corba.ee.internal.core.IOR.<init>(IOR.java:238)
at com.sun.corba.ee.internal.iiop.messages.LocateReplyMessage_1_2.read(L
ocateReplyMessage_1_2.java:137)
at com.sun.corba.ee.internal.iiop.IIOPInputStream.unmarshalHeader(IIOPIn
putStream.java:126)
at com.sun.corba.ee.internal.iiop.IIOPConnection.getResponse(IIOPConnect
ion.java:671)
at com.sun.corba.ee.internal.iiop.IIOPConnection.send(IIOPConnection.jav
a:778)
at com.sun.corba.ee.internal.corba.InitialNamingClient.locateObject(Init
ialNamingClient.java:786)
at com.sun.corba.ee.internal.corba.InitialNamingClient.getIORUsingHostIn
fo(InitialNamingClient.java:597)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolveCorbaloc(I
nitialNamingClient.java:573)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolveUsingORBIn
itRef(InitialNamingClient.java:544)
at com.sun.corba.ee.internal.corba.InitialNamingClient.cachedInitialRefe
rences(InitialNamingClient.java:1080)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolve_initial_r
eferences(InitialNamingClient.java:981)
at com.sun.corba.ee.internal.corba.ORB.resolve_initial_references(ORB.ja
va:2425)
at com.sun.enterprise.naming.SerialContext.getProvider(SerialContext.jav
a:52)
at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:120
)
at javax.naming.InitialContext.lookup(Unknown Source)
at AdviceClient.go(AdviceClient.java:16)
at AdviceClient.main(AdviceClient.java:10)
[ February 24, 2006: Message edited by: Sandeep MP ]
Zhou Xiao
Greenhorn

Joined: Jan 07, 2006
Posts: 27
I have the same problem. Could anybody help us out, please?


Would be an SCBCD
Zhou Xiao
Greenhorn

Joined: Jan 07, 2006
Posts: 27
Hi, I've solved my problem.

Please check your java software version. My problem is that I used java 5.0.
MI Mohammed
Ranch Hand

Joined: Feb 16, 2005
Posts: 146
Hi guys,
We at the ranch have solved the Advice app problem before.
All the same, here are some facts.
1. Java 5.0 is not supported. So you either have to stick with
the recommended Java 1.3 0r go for 1.4.

2. With some versions of 1.4 (window version), you might experirence some bug problems. But just follow the link for the solutions to running
the advice app.
http://www.coderanch.com/t/161481/java-EJB-SCBCD/certification/AdviceClient-Solution

If you still experience any problem, pls post the JDK version, J2EE RI
version and the OS. Bet you, i will be there to sail you guys out.

Hope it helps.


SCJA(Beta) SCJP 1.4 SCWCD 1.4 SCBCD 1.3 SCBCD 5.0 beta <br />The more practice we get, the better we are at the exams and in life in general. Pls join me at My DEN.
Sandeep Prabhakar
Ranch Hand

Joined: Dec 22, 2005
Posts: 59
Hey Folks,
Finally got the Advice Client to Run. I would like to share the problem that I was facing. I had both 1.5 and 1.4 versions of java installed. In the CLASSPATH and PATH system variables, I removed the entries corresponding to 1.5. But still the OS was using the 1.5 version .
I gave the absolute path for javac and java for 1.4 and it worked.
Hmmmmm. After nearly one week of research , I finally could run the client . Thanks to all the ranchers who tried to help me.


Cheers,
Sandeep
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Not Able To Run The Advice App Client given in Head First EJB