my dog learned polymorphism*
The moose likes EJB Certification (SCBCD/OCPJBCD) and the fly likes JDK 6 and J2EE 1.31 Compatibility Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Certification » EJB Certification (SCBCD/OCPJBCD)
Bookmark "JDK 6 and J2EE 1.31 Compatibility" Watch "JDK 6 and J2EE 1.31 Compatibility" New topic
Author

JDK 6 and J2EE 1.31 Compatibility

Javier Sanchez Cerrillo
Ranch Hand

Joined: Aug 02, 2006
Posts: 152
Hi ranchers. I'd like to know if there are compatibility issues between these 2.

I have installed both JDK 6 and J2EE 1.3.1 on my system and I'm following "Head First EJB" from Kathy and Bert.

When I start "j2ee -verbose", I get the following error:

Exception in thread "main" java.lang.NoClassDefFoundError
com/sun/corba/se/internal/util/IdentityHashTable

Followed by a Stack Trace.

Regards and Thank you!


SCJP 5.0 95%<br /> <br />The greatest enemy of knowledge is not ignorance, it is the illusion of knowledge.
Shivani Chandna
Ranch Hand

Joined: Sep 18, 2004
Posts: 380
advised to use only jdk1.3 with j2ee1.3

rgds.


/** Code speaks louder than words */
srini sri
Greenhorn

Joined: May 19, 2008
Posts: 2
J2EE 1.3 works with jdk 1.3 and jdk 1.4

In headfirst book it was said that some version of jdk 1.3 has some bug in working with j2ee (people: dont take this seriously). so, i suggest is jdk 1.4.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: JDK 6 and J2EE 1.31 Compatibility
 
Similar Threads
Servlet Exception
Scripting Invalid
Stateful Bean Naming Exception
Do I need to install Java EE ?
Android installation