• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

which version of servlets/JSP

 
Gagan Indus
Ranch Hand
Posts: 346
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Which version of
-Servlets
-JSP
is covered by SCWCD-exam ?
i guess Servlets 2.2 , and JSP 1.2 , is it so?
so do we need to bother wid servlets 2.3 and <b>web-app_2_3.dtd </b> ?
are the differnces in version-change significant ?
plz clarify
------------------
Gagan (/^_^\) SCJP2
Die-hard JavaMonk -- little Java a day , keeps u going .
 
Carl Trusiak
Sheriff
Posts: 3341
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Objective 3
3.1 Identify the uses for and the interfaces (or classes) and methods to achieve the following features:
Servlet context init. parameters
Servlet context listener
Servlet context attribute listener
Session attribute listeners

3.2 Identify the WebApp deployment descriptor element name that declares the following features:

Servlet context init. parameters
Servlet context listener
Servlet context attribute listener
Session attribute listeners

3.3 Distinguish the behavior of the following in a distributable:
Servlet context init. parameters
Servlet context listener
Servlet context attribute listener
Session attribute listeners


Listeners where introduced with Servlets 2.3 and do not exist in Servlets 2.2 so, the Exam covers Servlet 2.3 The JSP version that is associated with Servlet 2.3 is JSP 1.2
 
Gagan Indus
Ranch Hand
Posts: 346
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hey thankx Carl !! for quick help
wot a logical way to reach conclusion !
i was jus wondering which specs version to download
now i got da answer
so we shld concentrate on Servlets 2.3 and JSP 1.2
------------------
Gagan (/^_^\) SCJP2
Die-hard JavaMonk -- little Java a day , keeps u going .
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic