Win a copy of Learn Spring Security (video course) this week in the Spring forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

J2EE and Windows 98?

 
Neelima Kalidindi
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm am just beginning to gather material on the SJWCD exam. The J2EE SDK I found on Sun's site says its not Windows 98 compatible. Is there an SDK version that is windows 98 compatible and servlet/jsp enabled ?
thanks
Neelima
 
Chintan Rajyaguru
Ranch Hand
Posts: 341
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think what Sun really means is that not ALL the features are 98 competible. I think as far as JSP and Servlet are concerned win98 should be fine.
But, please note that you DO NOT need j2sdkee for servlets and JSPs. you just need to download Tomcat (an official implementation of Servlet 2.3 and JSP 1.2 specifications). Thought Tomcat might say the same thing (not competible with win 98), I think JSP and Servlet should work. I have used JSPs and Servlets on Tomcat on win98.

Is there an SDK version that is windows 98 compatible and servlet/jsp enabled ?
I don't think so.

Hope this helps
Chintan
 
Neelima Kalidindi
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Chintan. Yes, tomcat documentation suggests that its not 98 compatible too I will however install it and try it out. What about the java side of things ? So are you saying all the software I need is tomcat and no JDK installation ?
Do you know of any documentation on software requirements for the SJWCD exam ?
thanks!
Neelima
 
Ram Dhan Yadav K
Ranch Hand
Posts: 321
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This link should help you a lot.
http://www.javaranch.com/scwcdlinks.jsp
 
Neelima Kalidindi
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat install document suggests I need JDK 1.2 or above (JDK 1.3.1 recommended) to run servlets and JSPs using tomcat as the engine.
http://jakarta.apache.org/tomcat/tomcat-4.0-doc/appdev/installation.html
Also, SDK 1.3.1 is windows 98 compatible. Its the J2EE that isnt compatible.
http://java.sun.com/j2se/1.3/download-windows.html
thanks Chintan,Ram!
Neelima
 
Chintan Rajyaguru
Ranch Hand
Posts: 341
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes you are absolutely right. I think you got the point but let me reiterate,
You do need JDK 1.2 or higher (preferably 1.3.1) which is win 98 compatible.
You need Tomcat (which should work just fine on win 98 for Servlets and JSPs)
You do NOT need j2sdkee (enterprise edition of JDK)
Little tip:
If you install Tomcat and JDK, and you are going to compile Servlet classes with JDK, make sure that you have servlet.jar file in classpath or it is in the [jdk installation directory]\jre\lib
 
Neelima Kalidindi
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I downloaded and installed JDK 1.3.1_02 and Tomcat 4.0 and ran "HelloWorld" code successfully
Thanks Chintan... The tip on including classpath was very helpful !
Onwards to real preparation now !
Neelima
 
Neelima Kalidindi
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oh... forgot to mention. I found the Tomcat installation instructions from Marty Hall really helpful.
Configuring and Using Tomcat 4.0
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic