File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes Java Plug-in misbehaives Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "Java Plug-in misbehaives" Watch "Java Plug-in misbehaives" New topic
Author

Java Plug-in misbehaives

Gennady Shapiro
Ranch Hand

Joined: Sep 25, 2001
Posts: 196
Has anyone tried to resize a java plug-in on a html page? It won't resize, unlike <Applet>.
Simple code like below does not work for me.

function resizeTree() {
var width = document.body.clientWidth;
var height = document.body.clientHeight;
document.DocumentTree.setSize(width, height);
}

...
<jsp lugin type="applet"
code="qitanalytics.gui.tree.TreeViewer"
codebase="/classes/QITAnalytics@QITAnalytics"
name="DocumentTree">
<jsp arams>
<jsp aram name="scriptable" value="true" />
<jsp aram name="mayscript" value="true" />
<jsp aram name="treedata"
value=
"<%=tree.write(location)%>"
/>
</jsp arams>
<jsp:fallback>
<p>unable to start plugin </p>
</jsp:fallback>
</jsp lugin>


Suggestions anyone?
Thanks
P.S. sorry for stupid faces, they replaced ":" + "p"
[ March 28, 2002: Message edited by: Gennady Shapiro ]
Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17249
    
    6

P.S. sorry for stupid faces, they replaced ":" + "p"
That is too funny.
Sorry though that I can't help with the actual problem. I haven't seen or tried that.
Mark


Perfect World Programming, LLC - Two Laptop Bag - Tube Organizer
How to Ask Questions the Smart Way FAQ
Madhav Lakkapragada
Ranch Hand

Joined: Jun 03, 2000
Posts: 5040
sorry for stupid faces, they replaced
Edit your post and "Disable Smiles" at the bottom before saying "Add Reply" or whatever the button says.
- satya


Take a Minute, Donate an Hour, Change a Life
http://www.ashanet.org/workanhour/2006/?r=Javaranch_ML&a=81
Marcus Green
arch rival
Rancher

Joined: Sep 14, 1999
Posts: 2813
What version of the JDK are you using?


SCWCD: Online Course, 50,000+ words and 200+ questions
http://www.examulator.com/moodle/course/view.php?id=5&topic=all
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Java Plug-in misbehaives
 
Similar Threads
applet in JSP using firefox
prolem while calling javascript method from applet in Netscape6.2
problem of JSObject in Netscape6.2
problem of applet in Netscape 6.2 while usinf JSObject
jsp:param