Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

TOMCAT: Problems in installation (windows98)

 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
(Op: Windows98)
I unzipped the tomcat. I follwed the instructions of my book and assigned the envirnment varialbe (in the C;\AUTOEXEC>BAT ) of TOMCAT_HOME as below
TOMCAT_HOME=C:\unzipped\jakarta-tomcat-4.0.3\jakarta-tomcat-4.0.3\bin

Now I am double clicking startup batch file (in the \bin directory)
This is the message I am getting
JAVA_HOME environment variable is not defined.
This environment variable is needed to run this program Label is not found
C:\unzipped\jakarta-tomcat-4.0.3\jakarta-tomcat-4.0.3\bin
I really appreciate your help in this regard
Reddi
 
Muhammad Farooq
Ranch Hand
Posts: 356
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Reddi,
Please follow this link and you will find the solution hopefully.
 
Saif Ullah
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi reddi, please follow this sequence It will help you a lot.

1. install tomcat after unzipping to any of the directory. then change the folder name to " tomcat".
2. Then go to "start", click help, then system information in search box, new window opened.
3. Then click "tool", then click "system configuration utilities, then click the "environment" tab.
4. click new add TOMCAT_HOME and value = dir\tomcat
5. click new add JAVA_HOME and value = dir\jdk1.3 or your version of jdk
6. Then mark path, and add dir\jdk1.3\bin, JAVA_HOME\bin
7. Then copy and paste "servlet.jar" file into the directory of jdk1.3\jre\lib\ext, to include Servlet classes and interfaces in the Compiler

This will permanently solve the problem of classpath setting,
enjoy a lot, and pray for me, I am also new to SCWCD, and planning to appear in the exam during july or august, pray for me.
Thanks a lot
 
Jessica Sant
Sheriff
Posts: 4313
Android IntelliJ IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"Reddi"-
Welcome to the JavaRanch! Please adjust your displayed name to meet the JavaRanch Naming Policy. You can change it here.
Thanks! and welcome to the JavaRanch!
 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Saif,
1. install tomcat after unzipping to any of the directory. then change the folder name to " tomcat".
2. Then go to "start", click help, then system information in search box, new window opened.
3. Then click "tool", then click "system configuration utilities, then click the "environment" tab.
----------
IT seems to me the above suggestions are with regard to win2000, but I am using Win98. IT did not work. After typing "system information" in the text box of search, I did not see any tool.
Reddi
 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I downloaded tomcat3.2.4 and unzipped it directly into C:\. I changed the name of the directory as tomcat324(C:\tomcat324).
The values given for JAVA_HOME and TOMCAT_HOME variables are as below.
These are my C:\AUTOEXEC.BAT file details:
--------------------------------------------------
@ECHO OFF
rem
rem *** DO NOT EDIT THIS FILE! ***
rem
rem This file was created by the System Configuration Utility as
rem a placeholder for your AUTOEXEC.BAT file. Your actual
rem AUTOEXEC.BAT file has been saved under the name AUTOEXEC.TSH.
rem
SET PATH=C:\JDK1.2.1\BIN;C:\TCLITE\BIN;%PATH%
JAVA_HOME=C:\JDK1.2.1
TOMCAT_HOME=C:\tomcat324
---------------------------------------------------
When I double click startup batch file(C:\tomcat324\bin), it gives the follwoing message:
You must set JAVA_HOME to point to at your Java Development Kit Installation.
Is anything wrong in my Autoexec.bat file set up??. I desparately need the tomcat configured. Thanks for help
 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Now I am getting a different message. This is my latest AUTOExec.Bat file details:
--------------------------------------------
@ECHO OFF
rem
rem *** DO NOT EDIT THIS FILE! ***
rem
rem This file was created by the System Configuration Utility as
rem a placeholder for your AUTOEXEC.BAT file. Your actual
rem AUTOEXEC.BAT file has been saved under the name AUTOEXEC.TSH.
rem
SET PATH=C:\JDK1.2.1\BIN;C:\TCLITE\BIN;%PATH%
SET JAVA_HOME=C:\JDK1.2.1
SET TOMCAT_HOME=C:\tomcat324
--------------------------------------------
Now When I double click startup batch file(C:\tomcat324\bin directory), I am getting the following message:
........................................
Out of environment space
Out of environment space
Unable to set CLASSPATH dynamically.
NOTE: To set the CLASSPATH dynamically on Win9X systems only DOS 8.3 names may be used in TOMCAT_HOME!
Setting your class path statically.
Out of environment space
Out of environment space
Out of environment space
Using CLASSPATH:
Starting Tomcat in new window
........................................
When I execute http://localhost:8080/ in the browser, I donot see any default Tomcat Page, instead it says THE PAGE CANNOT BE DISPLAYED
What to do next??? TIA
J Reddi
 
Muhammad Farooq
Ranch Hand
Posts: 356
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
right click on startup.bat>> click properties>> click memory tab>>set initial environment to 4096 and click apply, a short cut for startup will appear use that for startup, follow the same procedure for shutdown.bat
HIH,
 
Saif Ullah
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
J reddi !
The previous mail is regarding window me. I don't know why it is not working with window 98.
Now to overcome the problem of " out of environment space" just go to your tomcat\bin directory. and do the following steps.
1. Double click the startup, then click properties and then memory tab, and set the "initial environment to 4096". click ok, restart the startup again.
2. Follow the same procedure with the shutdown.
I am sure, the out of environment problem will be solved.

Enjoy your studies.

A Java Student
Saif Ullah
SCJP2
 
Saif Ullah
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi J reddi!
Sorry the same above solution has already been sent by Mr. Farooq, I did not read that solution before sending my previous mail, I am feeling shame, excuse me please everybody whoever annoyed due to my previous mail especially Mr. Farooq
Thanks in anticipation

A Java Student
Saif Ullah
SCJP2
 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Muhammad/Saif,
The "out of environment" been taken careof.
Yes I did what you folks suggested. Yes two icons poped up as short cuts in the \bin folder. I double clicked startup batch file(in the \bin folder). Finally a, Finshed _STARTUP window pops and stays. It has below message
----------------------------------------------------
Unable to set CLASSPATH dynamically.
NOTE: To set the CLASSPATH dynamically on Win9X systems
only DOS 8.3 names may be used in TOMCAT_HOME!
Setting your class path statically.
Using CLASSPATH: C:\tomcat324\classes;C:\tomcat324\lib\at.jar;----------C:\JDK1.2.1\lib\tools.jar
Starting Tomcat in new window
---------------------------------------------------
I went ahead and When I execute http://localhost:8080/ in the browser, I donot see any default Tomcat Page, instead it says THE PAGE CANNOT BE DISPLAYED.
What to do next? TIA
J Reddi(SCJP)
 
Saif Ullah
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
J reddi!
Follow these steps again!
1. change the directory name to "tomcat"
2. set the path as

set TOMCAT_HOME =C:\tomcat
set JAVA_HOME =C:\JDK1.3 OR YOUR VERSION
set PATH = %PATH%%JAVA_HOME%\bin
3.copy & paste servlet.jar file to
jdk1.3\jre\lib\ext
4. This will solve the problem
May Allah Help you
Enjoy your studies

A Java Student
Saif Ullah
SCJP2
 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A New problem:
Hi Saif,
I changed the tomcat234 name to C:\tomcat.
My AUTOEXEC>BAT looks like this
*******************************
rem
SET TOMCAT_HOME=C:\tomcat
SET JAVA_HOME=C:\JDK1.2.1
SET PATH=%PATH%%JAVA_HOME%\bin;C:\TCLITE\BIN;%PATH%
CLASSPATH=,
*******************************
I have two question here: Is the CLASSPATH=, is reight??? I donot remeber what is C:\TCLITE\BIN;%PATH% is this syntax OK(I would like to know wheather it is bothering my tomcat)
I also added the servelet.jar file to C:\jdk1.2.1\jre\lib\ext

Now When I double click the startup batch file.
First window titled, Finshed _STARTUP window pops and stays. It has below message
----------------------------------------------------
Including all jars in C:\tomcat\lib in your class path
Using CLASSPATH: C:\tomcat\classes;C:\tomcat\lib\SERVLET.JAR;---------- C:\JDK1.2.1\lib\tools.jar
Starting Tomcat in new window
---------------------------------------------------
Soon second window titled java pops up and has message like:
.............................................
A non fatal internal JIT<3.00.078(x)>> Reloaction error:
NULL relocation target has occured in : org/apache/parser ------ etc etc
............................................
What to do next? TIA
J Reddi(SCJP2)
 
Muhammad Farooq
Ranch Hand
Posts: 356
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Saif Ullah:
Hi J reddi!
Sorry the same above solution has already been sent by Mr. Farooq, I did not read that solution before sending my previous mail, I am feeling shame, excuse me please everybody whoever annoyed due to my previous mail especially Mr. Farooq
Thanks in anticipation

A Java Student
Saif Ullah
SCJP2

Never mind, its OK Saif
Best of Luck
 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Saif/Muhammad,
I am still at the same place and not moving any inch. Above posting did not give me any clue about what you folks are referring to.
Please refer to MYPOSTING above (posted April 30, 2002 10:54 PM ). What I need to do to get my Tomcat going???
Thanks
J Reddi
 
J Reddi
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat is working
Thanks to everybody for help
J Reddi
6/MAy/2002
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic