aspose file tools*
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes tomcat installation Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "tomcat installation" Watch "tomcat installation" New topic
Author

tomcat installation

m.indira mandapati
Greenhorn

Joined: Feb 08, 2003
Posts: 6
i have installed tomcat 4.0 and j2sdk1.4.2.
I tried to start tomcat server then it is saying
you must set java_HOME tpo point your jsk installation.
Please reply me how to set that.
Thomas De Vos
stable boy
Ranch Hand

Joined: Apr 12, 2003
Posts: 425
This depends on the operating system.
Under Unix/Linux you will set execute the following in a terminal:
export JAVA_HOME=/opt/jdk1.4
under windows: set JAVA_HOME=c:\jdk1.4
Tomcat has a setclasspath.bat file. You can define the JAVA_HOME in here.


Try your free <a href="http://www.javacertificate.com" target="_blank" rel="nofollow">SCJP 1.4</a> certification centre.<br />Try your free <a href="http://www.j2eecertificate.com" target="_blank" rel="nofollow">SCWCD</a> certification centre.<br />Try your free <a href="http://www.ejbcertificate.com" target="_blank" rel="nofollow">SCBCD</a> certification centre.<br />Try your <a href="http://www.webspherecertificate.com" target="_blank" rel="nofollow">Websphere (Test 285) </a> certification centre.<br />Try your <a href="http://www.j2mecertificate.com" target="_blank" rel="nofollow">SCMAD</a> certification centre. (New)<br /> <br /><a href="http://blogs.javacertificate.com" target="_blank" rel="nofollow">Java/J2EE Certification Blogging</a>
m.indira mandapati
Greenhorn

Joined: Feb 08, 2003
Posts: 6
i did set the java home in catalina.bat file.
I started the server ,i see that path there.
But see a message out of environment space !
what is this , how to fix it.
I have created a classes folder in the web-apps/ROOT/WEB_INF
DO i need to set class path for this so that i can put all my .class files in this to run the application.
thank you
indira
mounika paruchuri
Greenhorn

Joined: Feb 12, 2002
Posts: 26
Try setting the environment variable JAVA_HOME to point to the jdk directory on your system.In windows you can do this by following steps..
mounika paruchuri
Greenhorn

Joined: Feb 12, 2002
Posts: 26
Try setting the environment variable JAVA_HOME to point to the jdk directory on your system.In windows you can do this by following steps..
right click on My computer,
click on Advanced tab,
click on Environment variables and you can see JAVA_HOME in the list or you can add one and set up the value
Hafizur Rahman
Ranch Hand

Joined: Sep 05, 2002
Posts: 98
Originally posted by m.indira mandapati:
But see a message out of environment space !

Please change the Windows DOS environment memory to highest one.


SCJP 2(94%), SCBCD 5.0(86%), SCDJWS(86%), SCEA 5 (I-73%, II/III-88%)
The illiterate of the 21st century will not be those who cannot read and write, but those who cannot learn, unlearn, and relearn. - Alvin Toffler
 
Don't get me started about those stupid light bulbs.
 
subject: tomcat installation