This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes Tomcat WebApp Deployment Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "Tomcat WebApp Deployment" Watch "Tomcat WebApp Deployment" New topic
Author

Tomcat WebApp Deployment

SAIYED
Greenhorn

Joined: Dec 10, 2004
Posts: 9
I am very new to tomcat and trying to get my very first web application up and running. This is the web app from the book Head First Servlet and JSP named Beer-v1

Tomcat version: 5.0.28
Platform: Windos 2000
Problem:
I have following structure

c:\tomcat\webapps\Beer-v1\form.html
c:\tomcat\webapps\Beer-v1\WEB-INF\web.xml
c:\tomcat\webapps\Beer-v1\WEB-INF\classes\com\example\web\BeerSelect.class

When I start the tomcat service and try to run my web app via IE
http://localhost:8080/Beer-v1/form.html , it gives me resource could not be found error.
If while tomcat is running, I create another folder under webapps and copy my form.html there and invoke it via IE it works fine. But if I stop and restart the tomcat service this also stops working.

i even made a copy of one of example application that comes with tomcat, that also act the same.
I know, I am doing something wrong and not setting some configuration files.
Please help
[ December 12, 2004: Message edited by: tomcat learner ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat WebApp Deployment