• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Should I use Tomcat to study? Which version?

 
Yuriy Zilbergleyt
Ranch Hand
Posts: 429
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I'm about to start studying for the SCWCD cert, and already have the Head First Servelets & JSP book. I leafed through it and noticed that the hands-on sections deal with Tomcat. The Jakarta site lists that the latest version of Tomcat (5.5.4) requires J2SE 5.0 to run (though with an additional download it can be compatible with 1.4.2.) But when I go to download J2EE SDK 1.4, the offered bundles have J2SE 1.4.2 instead of 5.0. Could someone explain to me how these all fit together? Does Tomcat provide it's own J2EE 1.4 classes, and only need J2SE to be installed on the system?

Thanks in advance!
Yuriy
 
Giju George
Ranch Hand
Posts: 333
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using Tomcat 5.0.27 , which still uses jdk1.4. Try that !!!
 
Yuriy Zilbergleyt
Ranch Hand
Posts: 429
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Great, thanks!

So am I right in understanding that Tomcat doesn't need external J2EE libs installed to function? It comes with it's own?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic