I'm about to start studying for the SCWCD cert, and already have the Head First Servelets & JSP book. I leafed through it and noticed that the hands-on sections deal with Tomcat. The Jakarta site lists that the latest version of Tomcat (5.5.4) requires J2SE 5.0 to run (though with an additional download it can be compatible with 1.4.2.) But when I go to download J2EE SDK 1.4, the offered bundles have J2SE 1.4.2 instead of 5.0. Could someone explain to me how these all fit together? Does Tomcat provide it's own J2EE 1.4 classes, and only need J2SE to be installed on the system?