permaculture playing cards*
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes Should I use Tomcat to study? Which version? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "Should I use Tomcat to study? Which version?" Watch "Should I use Tomcat to study? Which version?" New topic
Author

Should I use Tomcat to study? Which version?

Yuriy Zilbergleyt
Ranch Hand

Joined: Dec 13, 2004
Posts: 429
Hi all,

I'm about to start studying for the SCWCD cert, and already have the Head First Servelets & JSP book. I leafed through it and noticed that the hands-on sections deal with Tomcat. The Jakarta site lists that the latest version of Tomcat (5.5.4) requires J2SE 5.0 to run (though with an additional download it can be compatible with 1.4.2.) But when I go to download J2EE SDK 1.4, the offered bundles have J2SE 1.4.2 instead of 5.0. Could someone explain to me how these all fit together? Does Tomcat provide it's own J2EE 1.4 classes, and only need J2SE to be installed on the system?

Thanks in advance!
Yuriy
Giju George
Ranch Hand

Joined: Jun 08, 2004
Posts: 333
I am using Tomcat 5.0.27 , which still uses jdk1.4. Try that !!!


SCJP 1.4, SCWCD 1.4, SCBCD 1.3, SCEA
Yuriy Zilbergleyt
Ranch Hand

Joined: Dec 13, 2004
Posts: 429
Great, thanks!

So am I right in understanding that Tomcat doesn't need external J2EE libs installed to function? It comes with it's own?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Should I use Tomcat to study? Which version?