aspose file tools*
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes which version of JSP and servlet are been asked in the exam Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "which version of JSP and servlet are been asked in the exam" Watch "which version of JSP and servlet are been asked in the exam" New topic
Author

which version of JSP and servlet are been asked in the exam

chandrajeet padhy
Greenhorn

Joined: Jul 26, 2004
Posts: 21
Hi All,
newbie to scwcd ranch forum. Just wondering to find which version of JSP and servlet are been asked in the exam. Guessing from my understanding its servlet2.4 n JSP2.0. Could any of the successful and aspiring arms clear me on it.
Can someone tell me what HFSJ's mock tests is?
wr,
chandrajeet
Rafael Pereira
Ranch Hand

Joined: Mar 23, 2005
Posts: 32
For the current exam (310-081), the specifications are:

- Servlet 2.4
- JSP 2.0
- JSTL 1.1

This includes Expression Language, DD with XML Schema, no more SingleThreadModel (deprecated) etc.


Sun Certified Web Component Developer 1.4<br />Linux LPI Certified (LPIC-1)<br />Sun Certified Java Programmer 1.4
chandrajeet padhy
Greenhorn

Joined: Jul 26, 2004
Posts: 21
My gratitudes Rafael!
how abt this word form HFSJ?

-chandrajeet
trivikram Kumar
Ranch Hand

Joined: Feb 21, 2005
Posts: 172
Hi Chandrajeet,

HFSJ's mock exam is nothing but the final mock exam which is given at the end of the book in Head First Servlets And JSP's by Kathy Sierra,Bert Bates .

This exam is usually taken just 2 or 3 days before the final exam to know the level of our preparation.Hope this has answered your question.

Javainn.


Javainn<br /> <br />SCJP,SCWCD,SCBCD,<br />ICED (IBM-287,IBM-484,IBM-486)
IBM certified in DB2 V 8.1 Family Fundamentals (IBM 700)
Fernando Matias Valadao
Greenhorn

Joined: Feb 19, 2003
Posts: 26
Hey, guys!
Are you sure that the versions are 2.4 (Servlets) and 2.0 (JSPs)?
Here JavaRanch FAQ we can see that the versions are 2.3 (Servlets) and 1.2 (JSP).
I'm a bit confused about this!
I wish that I might have not read the wrong versions.
Could someone make it clear?
Thanks in advance

Fernando


"In the case of a nuclear attack, the protection of our records is essential, if this country is to carry on its economy and maintain our way of life."
Fernando Matias Valadao
Greenhorn

Joined: Feb 19, 2003
Posts: 26
Check this out, too: JavaRanch SCWCD Links

Fernando
chandrajeet padhy
Greenhorn

Joined: Jul 26, 2004
Posts: 21
guess the links are little older which talks abt the 310-080 exam pattern. but new ones are as Rafael pointed.
Thanks javainn for giving the full form of HFSJ.

-chandrajeet
Nicholas Cheung
Ranch Hand

Joined: Nov 07, 2003
Posts: 4982
Why dont you check which versions of JSPs/Servlets/JSTL are included in J2EE 1.4?

The exam name has already given hints for that.

Nick


SCJP 1.2, OCP 9i DBA, SCWCD 1.3, SCJP 1.4 (SAI), SCJD 1.4, SCWCD 1.4 (Beta), ICED (IBM 287, IBM 484, IBM 486), SCMAD 1.0 (Beta), SCBCD 1.3, ICSD (IBM 288), ICDBA (IBM 700, IBM 701), SCDJWS, ICSD (IBM 348), OCP 10g DBA (Beta), SCJP 5.0 (Beta), SCJA 1.0 (Beta), MCP(70-270), SCBCD 5.0 (Beta), SCJP 6.0, SCEA for JEE5 (in progress)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: which version of JSP and servlet are been asked in the exam