aspose file tools*
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes Steps to install tomcat 5.5.9 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "Steps to install tomcat 5.5.9" Watch "Steps to install tomcat 5.5.9" New topic
Author

Steps to install tomcat 5.5.9

Nicky Eng
Ranch Hand

Joined: Mar 26, 2005
Posts: 378
could anyone tell me the step of installation of tomcat ???

first of all, which file to download from Tomcat Dowload ???

please help...i kinda noob....


From NickyEng
Diploma in Computer Studies
SCJP 1.4
SCWCD 1.4
Formula 1 app by Maxis (Playbook)
Mat Williams
Ranch Hand

Joined: Jul 20, 2005
Posts: 215
Hi,

Firstly which version of Tomcat to install depends on which version of the JDK you have. All Tomcat versions 5.5.x require Jdk 1.5 all 5.0.x require JDK 1.4 or above.

I have JDK 1.4.2_06 and Tomcat 5.0.28 and they work well together.

Once you have the JDK worked out download the (Binary) .exe version of Tomcat (if you are running Windows), and then just double click the exe after it is downloaded. It will prompt you for all the stuff it needs, and from memory it finds the JDK itself to make it even easier.

HTH

Mat
Nicky Eng
Ranch Hand

Joined: Mar 26, 2005
Posts: 378
according to this website , there is a note saying that dont need JDK cos Tomcat 5.5 uses the Eclipse JDT Java compiler for compiling
JSP pages. I just need to have Java Runtime Environment 5.0 ...

now i have the JRE 5.0 , i want 5.5.9 tomcat, so i have to download the (binary).exe file from here right??

only .exe file i need to download??? cos i will be doing SCWCD based on HFSJ ......

please help....


[ September 09, 2005: Message edited by: Nicky Eng ]
Cai DongShan
Ranch Hand

Joined: Dec 07, 2004
Posts: 102
Yes, you only need jakarta-tomcat-5.5.9.exe if you are using PC with Windows platform.

I installed jdk-1_5_0_04-windows-i586-p.exe and jakarta-tomcat-5.5.9.exe for preparing SCWCD.


Best Regards,<br />DongShan<br /> <br />SCJP1.4, SCWCD1.4
Nicky Eng
Ranch Hand

Joined: Mar 26, 2005
Posts: 378
hi Dongshan Cai, thanks for the info....

i also download the same package as yours...not that i follow you...just that i heard a membere here said about 5.5.x above need jdk 1.5, so i downloaded it and install tomcat already.

and i set the path under "system variables" to allow me to compile file under Ms Dos command prompt...all the command path is under "C:\Program Files\Java\jdk1.5.0_04\bin", and this path is inside "path" variables under "system variables".

now my question is : do we really have to set JAVA_HOME and TOMCAT_HOME variables under "System Variables" ???
if we have to set them, then the path will be what???

anyone please help.....
Mat Williams
Ranch Hand

Joined: Jul 20, 2005
Posts: 215
Hi Nicky,

Sorry for the confusion I didn't realise that Tomcat 5.5.x only required the JRE not the JDK (Sorry I should have read the doco before stating something so definately).

moving on to the environment variables JAVA_HOME and TOMCAT_HOME. I don't believe that you need to worry about these. I certainly didn't with Tomcat 5.0.28. Tomcat sets them up when you install it.

Just try opening a web broswer and pointing it at http://localhost:8080 and see what happens. If the tomcat page somes up then you are in business as that is a JSP.

Mat
Nicky Eng
Ranch Hand

Joined: Mar 26, 2005
Posts: 378
hi Mat Williams,

its okay about the confusion....hehe...

i'm okay with installation of Tomcat already....hmm its time to start my HFSJ......hehe...

thanks for the info okay...thanks again.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Steps to install tomcat 5.5.9