This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

c:foreach--attribute problem

 
Joseph Clark
Ranch Hand
Posts: 48
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


Does anyone know why this code ...


produces this result ...

[Ljava.lang.String;@1629e71

Thank you.
[ January 07, 2006: Message edited by: Michael Clark ]
 
Marcelo Ortega
Ranch Hand
Posts: 528
Eclipse IDE Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Michael.

I have tried this code as is and i got an error saying that the <c:forEach> tag's items attribute does not suport expressions. Which JSTL version are you using? 1.1? If so, try specifying the following uri: "http://java.sun.com/jsp/jstl/core"

Kind regards,
Marzo.
[ January 08, 2006: Message edited by: Marzo Khaan ]
 
Joseph Clark
Ranch Hand
Posts: 48
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I was getting that error.
I think I have solved my problem.
I used c-rt.tld in standard.jar,and it worked.
That must be why they say to use c-rt.tld instead of c.tld.
[ January 08, 2006: Message edited by: Michael Clark ]
 
shanthisri mocherla
Ranch Hand
Posts: 119
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello friends
I was getting this error.org.apache.jasper.JasperException: The absolute uri: http://java.sun.com/jsp/jstl/core cannot be resolved in either web.xml or the jar files deployed with this application

can you please explian why am I getting this error??
Thank you very much in advance

Shanthi
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think that you should have jstl.jar and standard.jar in your lib directory.
 
shanthisri mocherla
Ranch Hand
Posts: 119
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Satou

I've copied both the jar files ,but did not place them in WEB-INF/lib.
That was the problem.

Thanks once again.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic