File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Help with JSTL

 
Stein Vom
Ranch Hand
Posts: 78
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A small example of jstl is not working. Although i copied the standard.jar and jstl.jar in WEB-INF/lib folder and made the entry required in web.xml. Can somebody help me?
 
Vishnu Prakash
Ranch Hand
Posts: 1026
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

made the entry required in web.xml


What entry did you make?

Try restarting your server.
 
Stein Vom
Ranch Hand
Posts: 78
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanx for the reply.

Wrote in jsp page:
<%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>

Copied standard.jar and jstl.jar in WEB-INF/lib folder.

Wrote in web.xml:
<web-app xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_3.xsd" version="2.3">

But in browser it is showing:
org.apache.jasper.JasperException: 絶対URI: http://java.sun.com/jsp/jstl/core はweb.xmlまたはこのアプリケーションを配備したJARファイルのどちらかでも解決できません
at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:105)
....
....
....


Ya, i tried that too. Restarted the Tomcat several times.
But the page showing the same exception.
 
Vishnu Prakash
Ranch Hand
Posts: 1026
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
SCWCD Exam covers servlet spec 2.4 and jsp spec 2.0
Use tomcat 5.X
[ January 31, 2006: Message edited by: Vishnu Prakash ]
 
Stein Vom
Ranch Hand
Posts: 78
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanx again. But it showing the same exception. I restarted the tomcat also.
 
Ravi Appana
Greenhorn
Posts: 13
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The version entry in the web.xml seems wrong. Please check it to be 2.4
 
Stein Vom
Ranch Hand
Posts: 78
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Ravi, thanks for the reply. Anyway it is my mistake that i didn't mentioned later, how that problem was later solved. I read somewhere that instead of using c.tld, we should use c-rt.tld. So i mentioned c-rt.tld in web.xml. That worked. Anyway thanks again for the effort.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic