aspose file tools*
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes HFSJ page 171-177 problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "HFSJ page 171-177 problem" Watch "HFSJ page 171-177 problem" New topic
Author

HFSJ page 171-177 problem

Nawar Gailani
Ranch Hand

Joined: Feb 08, 2005
Posts: 46
Hi there,
I have an error in Tomcat while trying out this tutorial:


I rechecked everything, and all seem fine! So I started NetBeans (the holy gift) and copy'n'paste all the java sources. Everything just worked fine! I overwrote the classes in my Tomcat directory with the ones compiled from NetBeans, but still the error there! Can anyone help?
Here are the source files (although I don't think this is the problem!):








is there something wrong with my code?
Can I use NetBeans for this exam and skip all that headeache?!
Thanks in advance
[ October 25, 2006: Message edited by: Nawar Gailani ]
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14688
    
  16

Can you post your application's directory stucture, and the url you are trying to access. It seems you are trying to access something like http://localhost:8080/listenerTest/ListenTest.do. Is your application called listenerTest ?
Please confirm.


[My Blog]
All roads lead to JavaRanch
Nawar Gailani
Ranch Hand

Joined: Feb 08, 2005
Posts: 46
Hi Satou,
The web.xml in:

And the three classes in:


The URL is:
http://localhost:8080/listenerTest/ListenTest.do

Hmmm! I think I found the 'silly' mistake! it is WEB-INF Nawar!!
Ok it is working now and I learned something: "Always prepare a strong coffee before you start coding!"

Thanks for your post Satou, and for this cup of coffee I'm drinking now!
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14688
    
  16

Glad you've found the problem
Patrick Gamble
Greenhorn

Joined: Nov 03, 2006
Posts: 2
Hi

I am having the same error msg - can you expand on what you found wrong in your web.xml file

Thanks

Patrick
Patrick Gamble
Greenhorn

Joined: Nov 03, 2006
Posts: 2
Sorry - disregard the last msg - realised what your problem was - not the file but the incorrect folder name. This wasn't my problem so I'm going to have to further re-examine it all

Thanks

Patrick
 
 
subject: HFSJ page 171-177 problem