Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Does EL turned off by default on Tomcat 5.5.9?

 
Denis Zjukow
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello!

I got a problem with turning on EL on Tomcat 5.5.9. It seems that it doesn't work by default. I only managed to make it work by using isELIgnored="false" in my jsp. I tried to do it through web.xml but it also failed. Well, I think EL must be turned on by default anyway? Am I right? Has anyone had such a problem? Thanks!
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You're probably using the wrong version of web.xml. Make sure you're using version 2.4, where EL is enabled by default.
http://faq.javaranch.com/view?ServletsWebXml
 
Denis Zjukow
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you Satou! The problem was that I didn't define 'web-app' properly. After I put the code into my deployment descriptor the problem disappeared.

<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
version="2.4">

...

</web-app>

Thanks for your help!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic