wood burning stoves 2.0*
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes Does EL turned off by default on Tomcat 5.5.9? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "Does EL turned off by default on Tomcat 5.5.9?" Watch "Does EL turned off by default on Tomcat 5.5.9?" New topic
Author

Does EL turned off by default on Tomcat 5.5.9?

Denis Zjukow
Ranch Hand

Joined: Mar 15, 2006
Posts: 39
Hello!

I got a problem with turning on EL on Tomcat 5.5.9. It seems that it doesn't work by default. I only managed to make it work by using isELIgnored="false" in my jsp. I tried to do it through web.xml but it also failed. Well, I think EL must be turned on by default anyway? Am I right? Has anyone had such a problem? Thanks!
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14688
    
  16

You're probably using the wrong version of web.xml. Make sure you're using version 2.4, where EL is enabled by default.
http://faq.javaranch.com/view?ServletsWebXml


[My Blog]
All roads lead to JavaRanch
Denis Zjukow
Ranch Hand

Joined: Mar 15, 2006
Posts: 39
Thank you Satou! The problem was that I didn't define 'web-app' properly. After I put the code into my deployment descriptor the problem disappeared.

<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
version="2.4">

...

</web-app>

Thanks for your help!
 
 
subject: Does EL turned off by default on Tomcat 5.5.9?