File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Web Component Certification (SCWCD/OCPJWCD) and the fly likes eclipse server plugin problems Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Web Component Certification (SCWCD/OCPJWCD)
Bookmark "eclipse server plugin problems" Watch "eclipse server plugin problems" New topic
Author

eclipse server plugin problems

Sigrid Kajdan
Ranch Hand

Joined: Jan 14, 2007
Posts: 72
Hello,

I'm using Eclipse's "run on server" option when developing webapps (server is tomcat).
I often encounter "mysterious behaviour". The biggest problem is, sometimes I just cannot get Eclipse to acknowledge changes in my files (e.g., the web.xml). I try restarting tomcat (in the server's view), I try "run on server" again,- nothing helps.
So, today I got impatient and removed the whole webapp under org.eclipse.wst.server.core/webapps/tmp0. I wanted to do "run on server" in a clean state. But now, when I try "run on server" on the project, nothing gets deployed any more, the directory mentioned above stays empty.

What can I do?

Also, I'm very insecure about the org.wst.server.core plugin in general.
For example, I often encounter the error message "No client found that could launch the application" (or so). But, I just click the same command ("run on server") again - changing nothing - and it works. Sometimes I have to click again still, but in the end it always works.
Does anybody also have problems with this plugin? What can one do in such cases? I did not find any documentation on the net on this plugin (there's the api doc of course, but I can't work through all that at the moment...)

I'd be grateful to hear others' experience & ideas,
thanks,
Sigrid
Ali Gohar
Ranch Hand

Joined: Mar 18, 2004
Posts: 572
Removing that server and configuring it again will resolve the problem.
Sigrid Kajdan
Ranch Hand

Joined: Jan 14, 2007
Posts: 72
thank you!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: eclipse server plugin problems
 
Similar Threads
Problem in using TOMCAT
TomCat running from Eclipse shows old cached data
Configuring webapp to use subdirectories
Tomcat 6, Eclipse and 404 errors oh my!
Eclipse + Tomcat + JSP's on the Mac