File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
Win a copy of Soft Skills: The software developer's life manual this week in the Jobs Discussion forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Which Editions are required?

 
Swapnil Sonawane
Ranch Hand
Posts: 190
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I came across one question. Which editions are required to develop a small application to run on mobile phones. Which editions are required to do that?

The answer they have given is : J2SE and J2ME

I don't understand why J2SE is required here. Any help?
 
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper
Posts: 4968
1
Hibernate Spring Tomcat Server
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, J2ME is a self-contained, micro-device development environment. If the application only used a handheld, only J2ME is required.

Quite often those questions involve a micro device, and some wording that indicates the data submitted by the micro-device will be read or used by a desktop application, which then precipitates the need for J2SE.

-Cameron McKenzie
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic