File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Developer Certification (SCJD/OCMJD) and the fly likes Modify Issues Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Certification » Developer Certification (SCJD/OCMJD)
Bookmark "Modify Issues" Watch "Modify Issues" New topic
Author

Modify Issues

Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17257
    
    6

I am having a problem that I can't quite figure out what is going on. I tried posting a couple of times earlier this week, but got no response, and deleted them when I thought I had the problem fixed.
But alas, even though I was wait() and notifyAll() on the wrong object, this was not what is causing the big problem.
When I click my book button, it makes the seat available changes to a DataInfo class then passes it to the modify method().
Here is where things go wrong, because After this point, I cn no longer access the db.db file. Any ideas what might be going on?
Please help
Mark


Perfect World Programming, LLC - Two Laptop Bag - Tube Organizer
How to Ask Questions the Smart Way FAQ
Ian B Anderson
Ranch Hand

Joined: Jun 26, 2001
Posts: 275
Hello,
I can't really help much but..
Do you get any exceptions thrown? Is there any way that you might be closing the db.db file? just try System.out.print and try and trace it that way.
When you say you can no longer access the db.db file do you mean you are getting null pointers errors?
In your locking system is anything still locked? (Is your client's lock actually relased?
Ian
Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17257
    
    6

Hmm. Well, I am pretty sure that the lock is released, but that might be a reason. I am getting Null pointers.
Before I even started the GUI, I had created a test class to test the lock and unlock, where one user had a lock, and the other tried to get it, and just waited till the first one released the lock, then it would get it, and that one worked, but maybe somehow, in my GUI, the call to unlock doesn't go through.
I'll have to test to see if unlock is running in my GUI. I know that it gets passed the call to unlock, but maybe the code within unlock skips over because of some if statement.
Thanks
Mark
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Modify Issues