• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JDK1.4???

 
Stephen Callaghan
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thinking of 'upgrading' my project before i upload it to 1.4 so i can take advantage of things like asserts and the new standard logging api. Anyone know if this would be a problem? (instructions just say any Java 2 runtime as long as its had a production release)
Cheers,
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well keep your 1.3 version, then try to upgrade it to 1.4 and see how it looks and feels. If you like it and want to be the first to attempt it, go ahead. It does meet the requirements of it being a production version of Java now.
If not, you can always go back to your 1.3 version.
Mark
 
Burk Hufnagel
Ranch Hand
Posts: 814
3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Stephen,
Did you update your code to use the assert and logging features in 1.4? If so, what do you think? Is it worth it? Knowing what you know now, would you do it again?
Lots of questions, I know, but it's an interesting topic.
Burk
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic