aspose file tools*
The moose likes Developer Certification (SCJD/OCMJD) and the fly likes NX:URLyBird Limitation on RMI Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Developer Certification (SCJD/OCMJD)
Bookmark "NX:URLyBird Limitation on RMI" Watch "NX:URLyBird Limitation on RMI" New topic
Author

NX:URLyBird Limitation on RMI

Leo Tien
Ranch Hand

Joined: Sep 10, 2002
Posts: 156
My assignment told me mustn't require the use of an HTTP server an mustn't require the installation of a security manager.
Whether it mean that mustn't send a serialized object between the client and server, so it needn't the properties named "java.rmi.server.codebase".
I don't fully understand "installation of a security manager", before this, i use RMI through .policy file to manager security.It whether i use .policy file?
Waiting for answer. Thanks a lot!
Andrew Monkhouse
author and jackaroo
Marshal Commander

Joined: Mar 28, 2003
Posts: 11476
    
  94

Hi Leo
Since you are not allowed to use a HTTP server, you cannot dynamically download code from the server. This should not cause you any problems. As you noted, this means that you do not need to set the codebase.
The policy file only takes effect when you use a security manager. That is, you would have used code similar to "System.setSecurityManager(new RMISecurityManager());" in your application. Since you cannot use a security manager, you do not need the policy file.
Regards, Andrew
[ August 04, 2003: Message edited by: Andrew Monkhouse ]

The Sun Certified Java Developer Exam with J2SE 5: paper version from Amazon, PDF from Apress, Online reference: Books 24x7 Personal blog
Leo Tien
Ranch Hand

Joined: Sep 10, 2002
Posts: 156
My assignment told me to use jdk 1.3.1, whether "System.setSecurityManager(new RMISecurityManager());" is used in this jdk version?
I'v seen RMISecurityManager is only used in jdk 1.1 or lower version, it exactly?
thanks, Andrew.
Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17256
    
    6

Yes 1.3.1 has RMISecurityManager. But like Andrew said, you shouldn't use one in your assignment. And in the new assignment, which you have, I believe it states that you MUST NOT use them.
Mark


Perfect World Programming, LLC - Two Laptop Bag - Tube Organizer
How to Ask Questions the Smart Way FAQ
Andrew Monkhouse
author and jackaroo
Marshal Commander

Joined: Mar 28, 2003
Posts: 11476
    
  94

Hi Leo
My assignment told me to use jdk 1.3.1

Can you tell me what this requirement is? Up until now, the only requirement I have seen is that the platform you develop on "must not have been superseded by a new production version for more than 18 months by the time you make your submission".
This is not specific to version 1.3.1. I would actually question whether 1.3.1 is even allowable under that instruction, as I think JDK 1.4 was released around September / October 2001.
Regards, Andrew
Leo Tien
Ranch Hand

Joined: Sep 10, 2002
Posts: 156
Dear Andrew:
You are right, my application submission version is 1.3.1, not jdk version. In my assignment have this:
Throughout this exercise, you must use exclusively the Java 2 platform. You may develop your code using any implementation of the Java 2 platform, but the submission that you return must have been tested and shown to work under a production (not development) version of the Sun Microsystems' Java 2 platform and that platform must not have been superseded by a new production version for more than 18 months by the time you make your submission.

What meaning "under a production (not development) version " is ? And whether it allows me to use jdk 1.3.1 version. (In fact, i always use jdk 1.4.1, until recieve this assignment.)
Andrew Monkhouse
author and jackaroo
Marshal Commander

Joined: Mar 28, 2003
Posts: 11476
    
  94

Hi Leo
What meaning "under a production (not development) version " is ?

Sun releases beta and "early-access" versions of it's products. These usually have either "beta" or "EA" in their names. You cannot use one of these products.
And whether it allows me to use jdk 1.3.1 version

I don't think so - I think version 1.4 has been out 18 months, so you can no longer use 1.3.x. Anyone else care to venture an opinion?
Regards, Andrew
Leo Tien
Ranch Hand

Joined: Sep 10, 2002
Posts: 156
Thanx, Andrew, i decide use jdk 1.4.1
Jim Yingst
Wanderer
Sheriff

Joined: Jan 30, 2000
Posts: 18671
It seems that SDK 1.4.0 was officially released (production version) March 1, 2002. Which would mean you've got a month left to use 1.3 . Sun really should have this sort of info available somewhere accessible.


"I'm not back." - Bill Harding, Twister
Andrew Monkhouse
author and jackaroo
Marshal Commander

Joined: Mar 28, 2003
Posts: 11476
    
  94

Sun really should have this sort of info available somewhere accessible.
Agreed. The nearest I could find was Sun's Archive page which tells you the EOL status for some products. But even then the information is not complete enough to make a categorical statement. JDK 1.4.0 has completed EOL, but JDK 1.3.1 is not mentioned?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: NX:URLyBird Limitation on RMI