Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

NX: mnemonics problem in windows XP

 
Terry Martinson
Ranch Hand
Posts: 293
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My mnemonics are acting weird in my windows XP development environment.
When I pull up the GUI, at first the underlines don't show up. However, if I then press the alt key only, they suddenly appear and work just fine. I expected that they would just automatically show as underlined when I first show the screen.
Sample GUI code that sets mnemonics:

Ideas?
TJ
 
joe black
Ranch Hand
Posts: 103
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you using the default swing look and feel?

I had the same problem, until I used Metal.
 
Jacques Bosch
Ranch Hand
Posts: 319
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Terry.
You are aware that that is a feature of XP that can be turned on/off?
If your app uses the system look and feel on XP, it will behave in that same way.
 
Terry Martinson
Ranch Hand
Posts: 293
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using the default swing look and feel. Also, I don't know much about the specific features of XP that Jacques mentioned.
Are most folks using the Metal look and feel rather than default? I had understood that we were supposed to use the default.
TJ
 
Jacques Bosch
Ranch Hand
Posts: 319
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Don't know about others, but I'm using System L&F.
So the app will look right at home on whatever OS it's running on.
 
Terry Martinson
Ranch Hand
Posts: 293
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jacques - so, do the mnemonics work for you? (i.e. display underlines right away, before you press the alt key the first time)
TJ
 
Xie Ruchang
Ranch Hand
Posts: 160
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi folks,
Those using XP can turn off the feature by
1. Right click the desktop and select Properties
2. Select the Appearance tab.
3. Click the Effects botton.
4. Uncheck the last item "Hide underlined letters for keyboard
navigation until I press the Alt key".
5. Click OK twice.
You need not press [Alt] to see the underline anymore.

Best Regards
 
Terry Martinson
Ranch Hand
Posts: 293
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Frankie -
YOU ROCK! Thanks - that worked perfectly on my Windows 2000 box at work, and I'll fix my home XP tonight.
TJ
 
Winona Whitener
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is there a way to override this programmatically? I can't rely on Windows or capable users with my program and I need to ALWAYS show the mnemonic letter.
 
Roel De Nijs
Sheriff
Posts: 9828
103
AngularJS Chrome Eclipse IDE Hibernate Java jQuery MySQL Database Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Winona,

I think it's better to open a new thread for your query (use an appropriate forum for it), instead of waking up the dead.

Kind regards,
Roel
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic