jQuery in Action, 2nd edition*
The moose likes Developer Certification (SCJD/OCMJD) and the fly likes B&S I Built My Project In 1.5, But It Bombs In1.4.2.  Is This OK? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Developer Certification (SCJD/OCMJD)
Bookmark "B&S I Built My Project In 1.5, But It Bombs In1.4.2.  Is This OK?" Watch "B&S I Built My Project In 1.5, But It Bombs In1.4.2.  Is This OK?" New topic
Author

B&S I Built My Project In 1.5, But It Bombs In1.4.2. Is This OK?

Bob Nedwor
hangman
Ranch Hand

Joined: Aug 17, 2005
Posts: 215

I built everything using JavaTM 2 Platform Standard Edition / Development Kit 5.0 / JDK(TM) 5.0.

And it runs great using java 1.5 (this version):
java version "1.5.0_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)
Java HotSpot(TM) Client VM (build 1.5.0_05-b05, mixed mode)

But if I try to run it using Java 1.4.2 (this version):
java version "1.4.2_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
Java HotSpot(TM) Client VM (build 1.4.2_05-b04, mixed mode)
Then it errors out with: "Exception in thread "main" java.lang.UnsupportedClassVersionError: suncertify/runme (Unsupported major.minor version 49.0)"

Is this OK? Especially if I document everything they ask for in the required "version.txt" to be delivered in our /docs directory???

Thanks for any hints.
--Bob


Bob N
SCJP - 1.4
SCJD - (B&S) Used 1.5 And It Runs On Solaris10
SCWCD - Thanks to HFSJ!!
Ed Tse
Ranch Hand

Joined: Sep 18, 2003
Posts: 183
yes, if your compliant level is 1.5, it won't run with 1.4.2. That's acceptable.


SCJP, Pre-SCJD (URLyBird 1.3.1), Teradata Cert'd Prof
Bob Nedwor
hangman
Ranch Hand

Joined: Aug 17, 2005
Posts: 215

OK, Thanks Ed. I am sticking with 1.5.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: B&S I Built My Project In 1.5, But It Bombs In1.4.2. Is This OK?