• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

URLyBird A beginer question

 
Pablo Aravena
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi friend

I have just started the programing of the assigment, but I don't know if I can use Java 1.5 because the assigment state is for java 2 platform and also I only have SCJP for java 1.2 (I got it in 2001)

please give some advise I really would like to use the java 1.5 new features

Thanks in advance
 
Oscar Gonzalez
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The Java 2 mean the platform but the edition is 5 (I prefer 5 than 1.5)

You can have Java 2 Platform 1.4 edition and so on, so you have to use Java 2 platform 5 edition .

 
Pablo Aravena
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
then there is no problem right?
 
Andrew Monkhouse
author and jackaroo
Marshal Commander
Pie
Posts: 11866
194
C++ Firefox Browser IntelliJ IDE Java Mac Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Pablo,

If you check the download page for JDK 5, you will see that the full name is "Java 2 Platform Standard Edition 5.0". So it is still a release for the Java 2 platform and there is no problem.

In fact, the instructions state that you must use a version of the JDK that has "not have been superseded by a new production version for more than 18 months by the time you make your submission". The only JDK that meets that criteria at present is JDK 5, so you do not really have a choice: you must use JDK 5.

Regards, Andrew
 
Pablo Aravena
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ok thank you very much for your help
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic