aspose file tools*
The moose likes Programmer Certification (SCJP/OCPJP) and the fly likes JQ+ Installation nightmare..Please help! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Programmer Certification (SCJP/OCPJP)
Bookmark "JQ+ Installation nightmare..Please help!" Watch "JQ+ Installation nightmare..Please help!" New topic
Author

JQ+ Installation nightmare..Please help!

Roger Chase
Greenhorn

Joined: Mar 20, 2001
Posts: 17
I have just spent the last 4 1/2 hours trying to get JQPlus 500 to run on my computer. Since my exam is Sunday and I can only study in the evenings, it has been a tremendous waste of time--at this point I'm regretting purchasing the software due to the difficulty in installation.
I have a Dell Inspiron running Windows 98. I am running Java version 1.3. I know it works b/c I run it with Forte and I just opened it to see if its still working....no problems. Also, at the Ms DOS prompt, typing: java -version results in: java version "1.3.0"
I downloaded jqplusroc.jar to C:\WINDOWS\TEMP.
I have included EVERYTHING I tried, perhaps you can identify the problem:
**************************************************************
Microsoft(R) Windows 98
(C)Copyright Microsoft Corp 1981-1998.
C:\WINDOWS>cd temp
C:\WINDOWS\TEMP>dir
Volume in drive C has no label
Volume Serial Number is 1424-1CDE
Directory of C:\WINDOWS\TEMP
.
03-20-01 10:02p .
..
03-20-01 10:02p ..
JQPLUS~1 JAR 289,390 03-20-01 11:00p jqplusroc.jar
1 file(s) 289,390 bytes
2 dir(s) 8,248.96 MB free
C:\WINDOWS\TEMP>java -version
java version "1.3.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0-C)
Java HotSpot(TM) Client VM (build 1.3.0-C, mixed mode)
C:\WINDOWS\TEMP>jar -xfjqplus~1.jar
Bad command or file name
C:\WINDOWS\TEMP>-jar JQPLUS~1.JAR
Bad command or file name
C:\WINDOWS\TEMP>jar jqplus~1 jar
Bad command or file name
C:\WINDOWS\TEMP>jar -xfjqplus~1.jar
Bad command or file name
C:\WINDOWS\TEMP>jar -xfJQPLUS~1.JAR
Bad command or file name
C:\WINDOWS\TEMP>jar -xfjqplus~1 jar
Bad command or file name
C:\WINDOWS\TEMP>jar -xfJQPLUS~1 JAR
Bad command or file name
C:\WINDOWS\TEMP>jar -xfjqplusroc.jar
Bad command or file name
C:\WINDOWS\TEMP>jar -xf jqplusroc.jar
Bad command or file name
C:\WINDOWS\TEMP>jar -xf JQPLUS~1 JAR
Bad command or file name
C:\WINDOWS\TEMP> jar -xf jqplus~1 jar
Bad command or file name
C:\WINDOWS\TEMP> jar -xf JQPLUS~1 JAR
Bad command or file name
C:\WINDOWS\TEMP> jar -xf JQPLUS~1.JAR
Bad command or file name
******************************************************
Lastly, clicking on the actual icon in the folder does nothing. I tried using WinZip to open it, and it just re-creates a copy of it which does mothing when you click on it. Do I have to have Forte open or something??? Is the fact that I have the SDK associated with the IDE messing things up?
A whole evening down the drain, I'm extremely frustrated, I hope someone can help.
Sincerely,
Roger Chase
PS....Part of the problem may be that I never use the MS DOS prompt.....
Angela Poynton
Ranch Hand

Joined: Mar 02, 2000
Posts: 3143
Unfortunatly I've never installed JQ+ but I expect you'll get some more people looking at this question in Programmer Certfication Study ... so I'm moving this over there.


Pounding at a thick stone wall won't move it, sometimes, you need to step back to see the way around.
Wong KK
Ranch Hand

Joined: Jan 15, 2001
Posts: 52
I haven't purchased JQ+.
But I think you should run it by:
java -jar xxx.jar
Paul Anilprem
Enthuware Software Support
Ranch Hand

Joined: Sep 23, 2000
Posts: 3293
    
    7
Probably haven't followed the installation instructions as given.
1. You are unable to run jar tool most probably because your jdk installation is screwed up. jar is a tool that comes with the jdk. If java runs, then jar should also run.
2. But that is not the only way. You can also use use WinZip to extract the files!
You problem is already described on our website: http://www.enthuware.com/jqplus/commonproblems.html
-Paul.

------------------
Get Certified, Guaranteed!
(Now Revised for the new Pattern)
www.enthuware.com/jqplus


[This message has been edited by Paul Anil (edited March 21, 2001).]


Enthuware - Best Mock Exams and Questions for Oracle/Sun Java Certifications
Quality Guaranteed - Pass or Full Refund!
Ronnie Phelps
Ranch Hand

Joined: Mar 12, 2001
Posts: 329
Roger,
Try to extract it first:
jar -xvf JQPLUS~1.JAR
This will create a directory called "jqplus" that contains the contents of the jar file.

Then go into the directory and execute this batch script at the prompt:
startJQPlus.bat
hope this helps.
kaffo lekan
Ranch Hand

Joined: Feb 13, 2001
Posts: 42
Roger
Try this ,extract all the files from the zip-file to desktop and then open the startJQPlus.bat file, it will run,what for few minutes.
This should help.
Roger Chase
Greenhorn

Joined: Mar 20, 2001
Posts: 17
Thank you all for your advice, I know your intentions were good. However, the reason I posted ALL the code was so that the problem could be accurately diagnosed...if you go through the code, you will see that I followed ALL the installation instructions--this includes the WinZip instructions(which the code doesn't show). I probably missing something simple, but you really have to look at the commands at the C prompt to offer an useful advice. I'm assuming that Java is installed correctly as: java -version results in a statement of the the version. Also, I just opened Forte and ran a sample program, so I know its on my computer.
Anyway, if anyone wants to take the time to actually look at the code I included, THAN offer advice, it would be much appreciated.

[This message has been edited by Roger Chase (edited March 21, 2001).]
Angela Lamb
Ranch Hand

Joined: Feb 22, 2001
Posts: 156
Your java command may work, but the jar command obviously does not. That is why you are getting the 'Bad Command or Filename' error. If the jar command were working properly, you would get either a incorrect usage message or a FileNotFoundException. Try using the explicit pathname of your jar command, for example:

c:\jdk1.3\bin\jar
Roger Chase
Greenhorn

Joined: Mar 20, 2001
Posts: 17
Hoooray! I uninstalled & re-installed the Java SDK----that seemed to do the trick! Thanks for the prompt response though, I do appreciate you time and effort!
Sincerely,
Roger
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JQ+ Installation nightmare..Please help!