wood burning stoves 2.0*
The moose likes Programmer Certification (SCJP/OCPJP) and the fly likes JDK1.2 or 1.3 for SCJP ? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Certification » Programmer Certification (SCJP/OCPJP)
Bookmark "JDK1.2 or 1.3 for SCJP ?" Watch "JDK1.2 or 1.3 for SCJP ?" New topic
Author

JDK1.2 or 1.3 for SCJP ?

sachin kumar Kansal
Greenhorn

Joined: Mar 25, 2001
Posts: 20
Hi
my self sachin .
i am preparing for SCJP and shedule to give on 18 june
There is a big confusion :
Questions in SCJP are tested on JDK 1.2 or JDK 1.3 ???
as i have JDK 1.3 and there is ambiguity with JDK 1.2
for example
void test (byte x)
{
switch (x)
{
case 'a' : // complies with a on JDK 1.3 but not on JDK 1.2
case 256:
case 0 :
default :
case 80 :
}
}
so please let me know which JDK is to be used JDK 1.2 or 1.3 ??
please reply urgently as i have to prepare .
regards
sachin
------------------

Thanks,<br />--Sachin Kansal
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: JDK1.2 or 1.3 for SCJP ?