aspose file tools*
The moose likes JNLP and Web Start and the fly likes javaw process keeps running after stopping webstart app Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JNLP and Web Start
Bookmark "javaw process keeps running after stopping webstart app" Watch "javaw process keeps running after stopping webstart app" New topic
Author

javaw process keeps running after stopping webstart app

Stijn Luyten
Greenhorn

Joined: Feb 07, 2003
Posts: 4
Hi everyone
We have the following problem:
For a project we need to start a locally installed jBoss server. This will be done via webStart.
So far so good, jBoss starts, runs and stops perfectly.
Only problem is that after it stops, it doesn't really stop; there is a javaw.exe process still running in the background, jBoss stopped, but still binds the ports it bound at startup.
When we run the app trough the regular javaw (with the jar and main-class manifest entry) the process isn't there anymore.
Some searching led me to believe that it's a bug in webstart (faq's from another webstart app said simply to stop the process via task-manager etc.)
Has anybody come accross a similar problem?
Thanks in advance.
Salomo Petrus
Greenhorn

Joined: Dec 07, 2006
Posts: 6
I've come across the same problem but still unable to fix it. Did you ever fix the problem? I noticed that this post was from 3 years ago so something should have changed probably :-). Thnx in advance
Buddhika Mawella
Ranch Hand

Joined: Jan 06, 2011
Posts: 39

I also have the same problem.


BM
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: javaw process keeps running after stopping webstart app