This week's book giveaway is in the Jobs Discussion forum.
We're giving away four copies of Soft Skills and have John Sonmez on-line!
See this thread for details.
The moose likes JNLP and Web Start and the fly likes Eclipse 3.1, J2SE1.5, RCP app.., JWS Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » JNLP and Web Start
Bookmark "Eclipse 3.1, J2SE1.5, RCP app.., JWS" Watch "Eclipse 3.1, J2SE1.5, RCP app.., JWS" New topic
Author

Eclipse 3.1, J2SE1.5, RCP app.., JWS

Jean-Claude Rouvinez
Ranch Hand

Joined: Aug 26, 2003
Posts: 35
Hi,

We try do deploy an ECLIPSE RCP application with Java Web Start and receive a NullPointerException.

Any idea how to solve this problem?


Stack Trace:
============
!SESSION Mon Oct 29 14:56:29 CET 2007 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2007-10-29 14:56:29.863
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.NullPointerException
at org.eclipse.equinox.launcher.Main.findMax(Main.java:871)
at org.eclipse.equinox.launcher.WebStartMain.searchFor(WebStartMain.java:116)
at org.eclipse.equinox.launcher.WebStartMain.basicRun(WebStartMain.java:72)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
at org.eclipse.equinox.launcher.WebStartMain.main(WebStartMain.java:56)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.javaws.Launcher.executeApplication(Unknown Source)
at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
at com.sun.javaws.Launcher.continueLaunch(Unknown Source)
at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)
at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)
at com.sun.javaws.Launcher.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)


Jean-Claude
Jean-Claude Rouvinez
Ranch Hand

Joined: Aug 26, 2003
Posts: 35
The eclipse version is 3.3.1 and not 3.1 !
Dennis Swanson
Greenhorn

Joined: Nov 29, 2007
Posts: 1
We're having the same problem in version 3.3.1.1. Has anyone gotten past this?
Jean-Claude Rouvinez
Ranch Hand

Joined: Aug 26, 2003
Posts: 35
Ensure that the org.eclipse.equinox.launcher plug-in is in the feature or in one of the included features.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse 3.1, J2SE1.5, RCP app.., JWS