aspose file tools*
The moose likes Performance and the fly likes VisualGC help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Performance
Bookmark "VisualGC help" Watch "VisualGC help" New topic
Author

VisualGC help

Steve Chambers
Greenhorn

Joined: Sep 19, 2006
Posts: 28
Not sure if this is the correct location for this question but here I thought I would give it a shot.

I am trying to run visual GC on linux. I keep getting the error below and can't find any help from google. Does anyone know what I need to do to get the program to work? I set the display to be :0 and "" and it doesnt work.

Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using '' as the value of the DISPLAY variable.
Peter Chase
Ranch Hand

Joined: Oct 30, 2001
Posts: 1970
What happens if you try to run other X Windows applications (xterm, xclock...), in the same way? If they fail similarly, then you don't have a Java issue, you have a Unix issue.


Betty Rubble? Well, I would go with Betty... but I'd be thinking of Wilma.
Doug Slattery
Ranch Hand

Joined: Sep 15, 2007
Posts: 294
Hi Steve,

Are you trying to start it from a shell or the gui console. Sounds like X and your window manager may not be running. Run the command ps -ef | grep "X11" and see if you get any X11 lines in the resulting process list. If not, X isn't running. I believe you can run the startup script startx which will kick it off. I'm not in front of a machine now, so I'm not sure what directory the startup script is in. I believe you also have to be root to start it. On redhat distro's, the gui login screen is on the alt-7 multiscreen.

If that doesn't work, check that X is installed. You might want to do this first if you're not sure. On Redhat distro's, you can execute the command rpm -q -a | grep -i X11. If you get some output, then it is probably installed. I'm not familiar with the other distro's, so I won't be much help in that regard.

I assume you're running X and your window manager on the console.?.? If so, try setting your DISPLAY env variable as follows:
export DISPLAY="localhost:0.0"
and then run gc. If your running X on an X terminal, change localhost to the ip address of the X terminal.

Hope this helps...
Aloha,
Doug

-- Nothing is impossible if I'mPossible
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: VisualGC help