File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Portals and Portlets and the fly likes Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Portals and Portlets
Bookmark ""simplest" portlet" Watch ""simplest" portlet" New topic

"simplest" portlet

a cadrian

Joined: Mar 08, 2006
Posts: 1

I'm new, created simple portlets and coped war file to .../jetspeed/web-inf/deploy folder
after restart tomcat server i saw this:

INFO: Server startup in 65063 ms
Creating war C:\Java\Apache Jetspeed 2.0\webapps\simplest.war ...
2006-02-25 19:13:58 org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive simplest.war
War C:\Java\Apache Jetspeed 2.0\webapps\simplest.war created
INFO: File: C:\Java\Apache Jetspeed 2.0\webapps\jetspeed\WEB-INF\deploy\simplest.war deployed
log4j:WARN No appenders could be found for logger (org.apache.commons.digester.Digester).
log4j:WARN Please initialize the log4j system properly.
JetspeedContainerServlet: starting initialization of Portlet Application at: simplest
JetspeedContainerServlet: initialization done for Portlet Application at: simplest

I stand that is all ok, and page should be work becouse
to deploy a portlet the Jetspeed 2 Wiki says:
"Copy the .war file to Jetspeed's deployment directory, by default this
is WEB-INF/deploy. Jetspeed will take care of automatically deplying the
portlet into the portlet registry and will also deploy the portlet as a
web application into the app server Jetspeed is deployed to."
But after open localhost:5580/jetspeed/simplest.psml
i don't see new portlet, only default page of jetspeed.

How can i ACTIVE that new portlet?

Here is my web.xml and portlet.xml files:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
<description>The world's simplest portlet</description>
<?xml version="1.0" encoding="UTF-8"?>
<portlet-app id="simplest" version="1.0"
<portlet id="simplest">
<display-name>Simple Display Name</display-name>
<title>Simple Title</title>
<short-title>The world's simplest portlet</short-title>
and simlest.psml:
<?xml version="1.0" encoding="UTF-8"?>
<page id="simplest">
<defaults skin="orange"
<fragment id="simplest-layout" type="layout" name="jetspeed::VelocityTwoColumns">
<fragment id="simplest-portlet" type="portlet" name="simplest::Simplest">
<property layout="TwoColumns" name="row" value="0"/>
<property layout="TwoColumns" name="column" value="0"/>
Jason Moors
Ranch Hand

Joined: Dec 04, 2001
Posts: 188
I think you are missing 'portal' from the url path.

I agree. Here's the link:
subject: "simplest" portlet
It's not a secret anymore!