It's not a secret anymore!
The moose likes Sockets and Internet Protocols and the fly likes Connection refused: connect Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Sockets and Internet Protocols
Bookmark " Connection refused: connect" Watch " Connection refused: connect" New topic
Author Connection refused: connect

Ketan Parekh

Joined: Sep 15, 2005
Posts: 20
hi, i have a written a simple program to connect to yahoo and read the content of the webpage.

It is giving me Exception: Connection refused:

i have also set the proxy settings in the program. I am able to connect to my company website but it is not connection to yahoo or google or msn etc.

can u suggest some solution to this problem.

import java.util.*;

public class crawler
public static void main(String args[]){


URL yahoo = new URL("");
URLConnection yc = yahoo.openConnection();

BufferedReader in = new BufferedReader(
new InputStreamReader(yc.getInputStream()));

String inputLine;

while ((inputLine = in.readLine()) != null)

Properties props= new Properties(System.getProperties());
props.put("http.proxySet", "true");
props.put("http.proxyHost", "");
props.put("http.proxyPort", "80");

Properties newprops = new Properties(props);

} catch (MalformedURLException me) {
System.out.println("MalformedURLException: " + me);
} catch (IOException ioe) {
//System.out.println("IOException:1" + ioe);



Thanks in Advance.

Isuru Sampath
Ranch Hand

Joined: Jun 26, 2003
Posts: 57
Hi Parekh,

Since I�m also spending a lot of my time behind a proxy I got the chance to try your problem out.

When I first tried I got an HTTP 407 Error which describes �Proxy Authentication required�.

Proxy authentication is not so much different form a basic http request. All you have to do is set the �Proxy-Authorization� parameter for the proxy.

Please note that I was behind an HTTP proxy and this example may not work if you are behind a SOCKS proxy.



No Winds No Waves
I agree. Here's the link:
subject: Connection refused: connect
It's not a secret anymore!