*
The moose likes Distributed Java and the fly likes Problem with RMIC Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Distributed Java
Bookmark "Problem with RMIC" Watch "Problem with RMIC" New topic
Author

Problem with RMIC

Bill White
Ranch Hand

Joined: Oct 27, 2002
Posts: 82
I am trying to RMIC a class called RMICreateDBImpl.
It resides in package com.createdb.rmi
When I use the command
rmic com.createdb.rmi.RMICreateDBImpl
I get the error:
error: Class com.createdb.rmi.RMICreateDBImpl not found.
When I use the command
rmic RMICreateDBImpl
I get the error:
error: File .\RMICreateDBImpl.class does not contain type RMICreateDBImpl as expected, but type com.
createdb.rmi.RMICreateDBImpl. Please remove the file, or make sure it appears in the correct subdire
ctory of the class path.
error: Class RMICreateDBImpl not found.
Now I realize that the second approach is wrong but, hey I was desperate.
Any idea what I could be doing wrong?
Thank You.
Maulin Vasavada
Ranch Hand

Joined: Nov 04, 2001
Posts: 1871
hi Bill
if u 've package com.createdb.rmi then i guess i have the directory hierarchy com/createdb/rmi as well, right?
in that case, u have to be in the "parent" of the "com" directory and do,
rmic com.createdb.rmi.RMICreateDBImpl
it would create stub/skel in this "parent" directory.
i tried with following,
i have dir,
/temp/myrmi
i put all *.java in myrmi. i did "cd temp" and then
rmic myrmi.CalculatorImpl
it worked.
if that doesn't work then probably u'd have to add "." to the CLASSPATH.
good luck.
regards
maulin
Bill White
Ranch Hand

Joined: Oct 27, 2002
Posts: 82
Thank you very much! You are da man!! I repeat you are da man!!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem with RMIC
 
Similar Threads
rmic assistance
The major.minor version error - please help
i have problem with command rmic (RMI)
i have problem with RMI
Why i cant rmic my HotelRemote?