wood burning stoves 2.0*
The moose likes Distributed Java and the fly likes rmi/iiop problems on xp & websphere Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Distributed Java
Bookmark "rmi/iiop problems on xp & websphere" Watch "rmi/iiop problems on xp & websphere" New topic
Author

rmi/iiop problems on xp & websphere

andrew beechey
Greenhorn

Joined: May 24, 2005
Posts: 18
Im attempting to test rmi/iiop on xp using websphere studio v5
on two seperate pcs on the same network.
I dont want to waste too much time of any one in the saloon,

but my one request would be ...
is there one GOOD site on the www that actually gives solutions to RMI problems?, as I've failed in my attempts to find it!.

the reported error i haves is access denied,

sorry for such patchy details but Im at home and not at work so I cannot get in depth details for you.

so far I've got dumpnamespace working and have got closer by corrrecting the sas.client.properties file location for kjs files,
but now i'm going to have to resort to using ethereal to see what traffice (if any)
is getting to my "remote" machine.
thanks in advance
Andy
Nathan Pruett
Bartender

Joined: Oct 18, 2000
Posts: 4121

"access denied" sounds like an error due to permissions not being set in the security policy. Once you have a chance, can you post the full error message from work?


-Nate
Write once, run anywhere, because there's nowhere to hide! - /. A.C.
andrew beechey
Greenhorn

Joined: May 24, 2005
Posts: 18
Nathan

thanks for bothering with this,

I will add the full error message once at work

I can confirm we are reaching the remote machine as we used ethereal/winpcap

to establish this as we thought it may be a firewall problem,

the message we are getting now on the client side is "naming service not available".

I'll get the full detials tomorrow

Thanks again

Andy
andrew beechey
Greenhorn

Joined: May 24, 2005
Posts: 18
Nathan

thanks once again for taking an interest in my problem,

we resolved it at work by setting the clients server orb settings

to the correct value e.g. not use localhost as the server by the ip address

of the ejb server

Thanks very much for the time you spent

Cheers

Andy
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: rmi/iiop problems on xp & websphere
 
Similar Threads
Websphere 6.0 Query
Adding JNDI functionality to vanilla IBM JDK 1.3.0
Questions regading RMI
Some RMI-IIOP qtns
CommunicationException when I do JNDI lookup