File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

rmi/iiop problems on xp & websphere

 
andrew beechey
Greenhorn
Posts: 18
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Im attempting to test rmi/iiop on xp using websphere studio v5
on two seperate pcs on the same network.
I dont want to waste too much time of any one in the saloon,

but my one request would be ...
is there one GOOD site on the www that actually gives solutions to RMI problems?, as I've failed in my attempts to find it!.

the reported error i haves is access denied,

sorry for such patchy details but Im at home and not at work so I cannot get in depth details for you.

so far I've got dumpnamespace working and have got closer by corrrecting the sas.client.properties file location for kjs files,
but now i'm going to have to resort to using ethereal to see what traffice (if any)
is getting to my "remote" machine.
thanks in advance
Andy
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"access denied" sounds like an error due to permissions not being set in the security policy. Once you have a chance, can you post the full error message from work?
 
andrew beechey
Greenhorn
Posts: 18
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nathan

thanks for bothering with this,

I will add the full error message once at work

I can confirm we are reaching the remote machine as we used ethereal/winpcap

to establish this as we thought it may be a firewall problem,

the message we are getting now on the client side is "naming service not available".

I'll get the full detials tomorrow

Thanks again

Andy
 
andrew beechey
Greenhorn
Posts: 18
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nathan

thanks once again for taking an interest in my problem,

we resolved it at work by setting the clients server orb settings

to the correct value e.g. not use localhost as the server by the ip address

of the ejb server

Thanks very much for the time you spent

Cheers

Andy
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic