File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Distributed Java and the fly likes PortableRemoteObject.narrow() returns null Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Distributed Java
Bookmark "PortableRemoteObject.narrow() returns null" Watch "PortableRemoteObject.narrow() returns null" New topic

PortableRemoteObject.narrow() returns null

Markus Oops

Joined: Jan 10, 2007
Posts: 1
Hi there

I've got some problem with runing an EJB application over RMI/IIOP.

I made the tutorial DukesBank from JBoss . After I successful could run the application, I tried to run it over RMI/IIOP. I thought, I just have to do change some properties. But it wasn't as easy as I expected.

When I run this code, the call PortableRemoteObject.narrow() returns null. I don't know why. The Object obj is a CORBAObjectImpl Object and for me it seems to contain all the necessary things.

I googled for this problem but I didn't find a resolution.

What I think is strange, when I debug the code, I see, that it uses the Sun classloader and not a JBoss classloader. Is this normal? Has anybody an idea, why the call PortableRemoteObject.narrow() returns null?

I'm using the following environment:
JDK: Sun JDK 1.5.0_09
JBoss: JBoss 4.0.5

Thanks for your help
[ January 10, 2007: Message edited by: Markus Oops ]
I agree. Here's the link:
subject: PortableRemoteObject.narrow() returns null
It's not a secret anymore!